UI/Display error with text at location enabling screen #120

Closed
opened 9 months ago by rugk · 2 comments
rugk commented 9 months ago

Avoid duplicates

  • Bug is not mentioned in the FAQ
  • Bug is specific for Android only, for general issues / questions that apply to iOS and Android please raise them in the documentation repository
  • Bug is not already reported in another issue

Technical details

  • Device name: Fairphone 3 (FP3)
  • Android version: 10 (Stock ROM)
  • App version: 2.0.3

Describe the bug

When the location services are disabled in Android system settings, the screen that asks the user to enable that has a display error with overlapping text.

Steps to reproduce the issue

  1. Disable location services completely.
  2. On the home page click on “location services disabled” (”Standortdienste deaktiviert”)
  3. You get to a screen titled with “risk assessment”. (”Risikoermittlung”)
  4. Up until the menu for other countries it looks all right. And further down the static explanation text (”Um zu erkennen…”) also looks ok. Only the big interactive part/prompt with the button for the user is absolutely distorted.

The texts “Ermittlungszeitraum aktivieren” (”enable detection period”) and “Standortverwendung erlauben” (”enable location access”) seem to overlay each other:

promptGpsReenable

BTW, the button works though. :)

(English translations are my guess, I have not double-checked whether these are

Expected behaviour

If I had to guess, I’d say this has been introduced with the latest update.
Using the app in German language.
Screen size is according to Wikipedia:
5.65 in (144 mm)
1080×2160 px FullHD+
427 ppi

Reproducible in dark and light mode.

Also reproducible with CWA v2.0.3: https://github.com/corona-warn-app/cwa-app-android/issues/2940 (Same bug text copied to both issues, only images changed.)

<!-- Thanks for reporting a bug 🙌 ❤️ Before opening a new issue, please make sure that we do not have any duplicates already open. You can ensure this by searching the issue list for this repository. If there is a duplicate, please close your issue and add a comment to the existing issue instead. Also, be sure to check our documentation first: https://github.com/corona-warn-app/cwa-documentation --> ## Avoid duplicates * [x] Bug is not mentioned in the [FAQ](https://www.coronawarn.app/en/faq/) * [x] Bug is specific for Android only, for general issues / questions that apply to iOS and Android please raise them in the [documentation repository](https://github.com/corona-warn-app/cwa-documentation) * [x] Bug is not already reported in another issue ## Technical details - Device name: Fairphone 3 (FP3) - Android version: 10 (Stock ROM) - App version: 2.0.3 ## Describe the bug When the location services are disabled in Android system settings, the screen that asks the user to enable that has a display error with overlapping text. ## Steps to reproduce the issue <!-- include screenshots, logs, code or other info to help explain your problem --> 0. Disable location services completely. 1. On the home page click on “location services disabled” (”Standortdienste deaktiviert”) 2. You get to a screen titled with “risk assessment”. (”Risikoermittlung”) 3. Up until the menu for other countries it looks all right. And further down the static explanation text (”Um zu erkennen…”) also looks ok. Only the big interactive part/prompt with the button for the user is absolutely distorted. The texts “Ermittlungszeitraum aktivieren” (”enable detection period”) and “Standortverwendung erlauben” (”enable location access”) seem to overlay each other: ![promptGpsReenable](https://hostux.pics/images/2021/04/23/promptGpsReenableCctg0df17f9ef3d423e6.png) BTW, the button works though. :) (English translations are my guess, I have not double-checked whether these are ## Expected behaviour <!-- A clear and concise description of what you expected to happen. ⟶ No display error, ## Possible Fix <!--- Not obligatory, but suggest a fix or reason for the bug ⟶ No idea. ## Additional context <!-- Add any other context about the problem here. --> If I had to guess, I’d say this has been introduced [with the latest update](https://github.com/corona-warn-app/cwa-app-android/releases/tag/v2.0.3). Using the app in German language. Screen size [is according to Wikipedia](https://en.wikipedia.org/wiki/Fairphone_3): 5.65 in (144 mm) 1080×2160 px FullHD+ 427 ppi Reproducible in dark and light mode. --- Also reproducible with CWA v2.0.3: https://github.com/corona-warn-app/cwa-app-android/issues/2940 (Same bug text copied to both issues, only images changed.)
fynngodau added the
upstream-cwa
label 9 months ago
Owner

Since you have identified the bug to be from upstream, it should suffice to report it there as their is nothing special we will need to do to fix it.

Since you have identified the bug to be from upstream, it should suffice to report it there as their is nothing special we will need to do to fix it.
Owner

Regardlessly, I already fixed this with 98146a15ff for CCTG, more or less on accident – merge conflicts are going to happen in this file anyhow. Upstream PR: https://github.com/corona-warn-app/cwa-app-android/pull/2947

Regardlessly, I already fixed this with 98146a15ff17af795062a96d59b89b0a2f304ec3 for CCTG, more or less on accident – merge conflicts are going to happen in this file anyhow. Upstream PR: https://github.com/corona-warn-app/cwa-app-android/pull/2947
fynngodau closed this issue 9 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.