You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
calckey/CHANGELOG.md

10648 lines
230 KiB
Markdown

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

# Changelog
All changes from v13.0.0 onwards, for a full list of differences read CALCKEY.md
## [13.1.3] - 2023-02-09
### Bug Fixes
- Fix: Hide unmute option when the user is blocked
### Features
- Feat: Mute and unfollow when blocking a user
- Feat: Unblock with follow button
- Refresh user when changed
- Feature/help_menu ([#9587](https://github.com/orhun/git-cliff/issues/9587))
Co-authored-by: ThatOneCalculator <kainoa@t1c.dev>
Reviewed-on: https://codeberg.org/calckey/calckey/pulls/9587
### Miscellaneous Tasks
- Chore: up vite
- Chore: update credits
## [13.1.2] - 2023-02-06
### Bug Fixes
- Fix: :bug: federate fedibird quote properly
https://codeberg.org/calckey/calckey/pulls/9399#issuecomment-758047
- Fixes & tweaks
- Fix: background color in classic view
- Fix: comply with nodeinfo 2.1
- Fix: nodeinfo links without inflamatory comments.
Sorry for everyone who I have hurt with this, I had a really bad day, I promise this will
be the last time something like this happened. Please read my public statement.
- Fix: ๐Ÿ› Poll choice length 256
Co-authored-by: Syuilo <Syuilotan@yahoo.co.jp>
Closes #9433
- Fix: :bug: better update detection logic
- Fix: header actions tooltips in timeline
- Fix: drive/files/create.ts endpoint
- Fix build
- Fix: chat realtime update
- Fix: heart reactions
- Fix: tooltip lingering
- Fix: render MkToast with Mfm
- Fix: return only first emoji but fully
- Fix: add purple to hannuka
- Fix: deliver queue
- Fix user list widget
- Fix dup
- Fix: avatars in grid, not seperate grids
- Fix: make perm selector look nicer
- Fix: Chats did nt update in realtime
- Fix: disable reloads on timeline
- Fix: heart reaction
- Fix: :bug: double name on splash
Closes #9500
- Fix: :bug: signin with ipv6
co-authored-by: Syuilo
- Fix(client): use proxied image for instance icon
- Fix: actually add swc to sw package
- Fix: :zap: use proxied image for instance icon on ticker
Closes #9426
- Fix style
- Fix: show mfm cheat sheet as popup instead of new window
- Fix
- Fix wrong locale
- Fix: update dialog
- Fix
- Fix: margin on tab button
- Fix lock
- Fix: Use โค๏ธ instead of โ™ฅ๏ธ
- Fix: :bug: following issues
Closes #9544
- Fix: :lock: improve tag search security
- Fix: reactions using unicode weren't processed
### Documentation
- Docs: YunoHost
- Docs: ๐Ÿ“ easy installers
- Docs: ๐Ÿ“ easy installer images
- Docs: ๐Ÿ“ aur
- Docs: ๐Ÿ“ aur badge
- Docs: ๐ŸŒ‹ Lavaforge
- Docs: no tensorflow
- Docs: :memo: clone depth 1
closes #9501
### Features
- Add -webkit-mask to line
- Feat: introduce devBuild
- Add back note-context wrapper
- Add back pfp in compose box when replying
- Feat: PWA icons
- Feat: :sparkles: dialog to remove follower
co-authored-by: atsu1125 <atsu1125@github>
### Miscellaneous Tasks
- Chore: remove links to misskey-hub
- Update pug description
- Chore: translated comments in MkPagination
- Chore: :fire: remove vue version from environment
why was this ever needed
- Chore: change code commit of pictogram to emoji
- Chore: rome linting
- Chore: add various keywords
- Chore: update patrons
- Chore: lavaforge links
- Chore: update patrons
- Chore: update patrons
- Update brnach
- Chore: reformat MkPagination
- Chore: reformat messaging/index.vue
- Chore: :wrench: remove eslint from service worker, up pnpm
- Chore: release notes
- Chore: up pnpm
- Chore: update german translations
- Update changelog
- Chore: formatting
### Performance
- Perf: :construction_worker: build backend with swc
Co-authored-by: pikokr <@paring@pikokr.dev>
### Refactor
- Refactor: :wrench: vite config
Co-authored-by: Syuilo <Syuilotan@yahoo.co.jp>
- Refactor: merge CI configs
- Refactor: :hammer: Use pnpm instead of yarn ([#9461](https://github.com/orhun/git-cliff/issues/9461))
Reasons:
1. `pnpm` is now an industry standard, being faster and less buggy than `yarn`.
2. Faster build time as builds are concurrent: 63 seconds down to 35 seconds!!
3. Resolves #9412
Co-authored-by: ThatOneCalculator <kainoa@t1c.dev>
Reviewed-on: https://codeberg.org/calckey/calckey/pulls/9461
- Refactor: :art: rome
- Refactor constants
Also added more standard media formats
- ๐ŸŽจ Improve structure / format of MkPagination.vue
- Refactor: online indicator
### Styling
- Style: outline instance name in ticker
- Style: border radius on instance ticker icon
- Style: :lipstick: ticker improvements
premature partial from #9415
## [13.0.6-rc] - 2023-01-04
### Bug Fixes
- Prevent notifications if the notification contains a note that is muted
- Fix padding on normal display
- Fix: Cliff design
- Fix: user view z-fighting
- Fix: overlapping user follow button in mobile view
- Fixes
- Fix
- Fix
- Fix
- Fixes
- Fix bot tag
- Fix????
- Fix mobile button
- Fix
- Fix
- Fix?
- Fix
- Fix shadows
- Fix?
- Fix
- Fix: Header of cliff.toml changed to automatically link to calckey.md
### Documentation
- Docker immutable install
- Docs: node 19
- Docs: ck
- Docs: changelog
- Docs: shrink changelogs
### Features
- Add checks to resolver and performOneActivity
- Add .js to the end of two type-scripts, fixing a critical error that crashes calckey
- Add antenna mark read functionality
- Add antenna mark read functionalityu
- Add .js to the end of two type-scripts, fixing a critical error that crashes calckey ([#9347](https://github.com/orhun/git-cliff/issues/9347))
- โœจ automatic changelog generation using git cliffy
### Miscellaneous Tasks
- Update yarn
- Chore: bump version number
- Chore: upgrade packages
- Chore: up pkgs
- Chore: deprecate `deckDivider`
## [13.0.5] - 2022-12-18
### Bug Fixes
- Fix typo
- Fix-docker-env-path ([#9241](https://github.com/orhun/git-cliff/issues/9241))
- Fix: use correct color for MkMoved
- Fixed additional path to .config
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
- Fix: ๐Ÿฅด
### Documentation
- Docs: ๐Ÿ“ more badges
- Docs: ๐Ÿ“ badges [CI Skip]
- Docs: ๐Ÿ“ weblate
- Docs: ๐Ÿ“ more images
- Docs: ๐Ÿ“ fix spacing
- Docker-compose-port-fix ([#9251](https://github.com/orhun/git-cliff/issues/9251))
- Docs: ๐Ÿฅด
### Features
- Feat: weblate!
- Feat: ๐Ÿฅด
- Feat: :package: upgrade to vite 4
### Miscellaneous Tasks
- Update example.yml with container names specified in docker-compose, to support running either a dev or production containers off the same configs
- Chore: lint
- Chore: dockerfile cleanup
- Chore: Update patron list
- Chore: remove unicode fault in KO
- Chore: update gitignore
- Chore: fix rebuild
### Refactor
- Refactor: :busts_in_silhouette: update cleo link
- Refactor: new repo link
### Testing
- Test: ๐Ÿฅด
## [13.0.4] - 2022-12-16
## [13.0.3] - 2022-12-16
### Bug Fixes
- Fix: ๐Ÿ› fix inconsistent theming
- Fix: css class match
- Fix: insert into correct textarea
### Documentation
- Docs: :memo: fix badge position
### Features
- Feat: Insert text at cursor for caption
### Refactor
- Refactor: rm .github folder
## [13.0.0] - 2022-12-16
## [13-rc1] - 2022-12-16
### Bug Fixes
- Fix
- Fix: :bug: wrong placement
- Fix?
- Fix broken order
- Fix: :alembic: messaging pagination
- Fix?
- Fix: :lipstick: calc style
- Fix
- Fix
- Fix???
- Fix
- Fix?????
- Fix: REALLY make sure there's no text decoration
- Fix groups button display
- Fix
- Fixxxxx
- Fix
- Fix
- Fix scroll anim bug?
- Fix
- Fix
- Fix imports
- Fix style
- Fix pinned users
- Fix pinned users list
- Fix: ๐Ÿ› no double import
- Fix: workaround for sticky image container header
- Fix i18n
- Fix pages index
- Fix pages swiping
- Fix?
- Fix chat message
- Fix pages margin
- Fix user profile
- Fix fill out profile step of tutorial
- Fix: :bug: fix image size in dms
- Fix: actually set in-dm to be true if in dm
- Fix serviceworker
- Fix
- Fix: don't show rtl if disabled, regardless of perms
- Fix
- Fix
- Fix locale
- Fix
- Fix defaults
- Fix patrons
- Fixes
- Fix gulpfile
- Fix again
- Fix out link
- Fix: don't do icon transform by default
- Fix #9140
- Fix cursor in note thread
- Fix problems from #9146
- Fix
- Fix
- Fix
- Fix
- Fix
- Fix cleo's oopsie
- Fix imports
- Fix import once and for all
- Fix migration
- Fix
- Fixes
- Fix
- Fix
- Fix
- Fix ap person to db model
fixed entries of movedToUri and added entries of alsoKnownAs
- Fixed it for good
- Fix more icons
- Fix remote move queue
- Fix queue?
- Fixed stupidness again
- Fix ??
- Fix import
- Fix path
- Fix liked pages
- Fix liked pages endpoint
- Fix??
- Fix remote move queue
- Fix queue?
maybe pls
debug log
fixed stupidness again
fix ??
fix import
im a idiot lol
make remote mig work
- Fix path
- Fix unicode weirdness
- Fix: call functions properly
- Fix viewing basic federaion info
- Fix: migration labels
- Fix: label
- Fix ckjs
- Fix calckeyjs
- Fix calckey-js | fix migration url
- Fix locale
- Fix alsoKnownAs federation
- Fix redis in ci
- Fix federation of moved to to pleroma
because it expects it to be non-existant if its null.
- Fix docker ci
### Documentation
- Docs: :memo: deps
- Docs: :memo: typo
- Docs: :memo: latest 18
- Docs: ๐Ÿ“ pm2
- Docs: more accessible links
- Docs: move intro to wip
- Docs: :memo: intro tutorial
- Docs: ๐Ÿ“ tips & tricks
- Docs: fix typo
- Docs: tips
- Docs: :memo: improve documentation, nginx
- Docs: :memo: tip
- Docs: :memo: open port tip
- Docs: ๐Ÿ“ alt text for calc
- Docs: ๐Ÿ“ typo
It's "available". Thank you luke :P
- Docs: ๐Ÿ“ typo
- Docs: ๐Ÿ“ official account
- Docs: another tip
- Docs: ๐Ÿ“ improve install instructions
- Docs: ๐Ÿ“ formatting
- Docs: ๐Ÿ“ optional deps
- Docs: custom locales
- Docs: a11y
- Docs: reflect last change in readme
- Docs: deps
- Docs: ๐Ÿ“ better links
- Docs: ๐Ÿ“ be more descriptive with new techs
- Docs: ๐Ÿ“ scylla will be optional
- Docs: ๐Ÿ“ better links
- Docs: ๐Ÿ“ be more descriptive with new techs
- Docs: ๐Ÿ“ scylla will be optional
- Docs: ๐Ÿ“ account migration
### Features
- Feat: :art: move reaction button
- Feat: :sparkles: Star button
- Feat: :art: add ripple to star react
- Feat: :art: add ripple to star react
- Feat: :sparkles: Toggle showing calckey updates as admin
- Feat: โœจ add `os.yesno` for yes/no questions
- Feat: :lipstick: add right margin to title text
- Feat: :sparkles: Allow importing follows from Pixelfed
- Feat: โœจ Append caption to textarea
- Feat: :sparkles: Managed hosting complete
- Feat: :lipstick: Phosphor icons!
- Feat: :lipstick: Phosphor icons!
- Add effects, japanese translation
- Feat: โœจ Page drafts
- Feat: Docker update script ([#9159](https://github.com/orhun/git-cliff/issues/9159))
- Feat: Docker update script ([#9159](https://github.com/orhun/git-cliff/issues/9159))
- Feat: :sparkles: Add delete all lists
- Add ui back
- Add local move follower migration
- Feat: customizable max note length
- Add check for already moved
### Miscellaneous Tasks
- Chore: :package: Update packages
- Update example
- Update deps
- Chore: :package: package upgrades
- Chore: :arrow_up: update deps
- Chore: :arrow_up: upgrade packages
- Chore: :arrow_up: yarn 3.3.0
- Update person model
### Performance
- Perf: :zap: load icons css last
- Perf: :zap: load icons css last
### Refactor
- Refactor readme
- Refactor: :alembic: try `active-class`
- Refactor: :recycle: Replace all `$ts` with i18n
- Refactor
### Styling
- Style
- Style
### Testing
- Test
- Test
- Test
- Test new chat layout
- Test
- Test
- Test
- Test
- Test explore page fix
- Test
- Test api docs
## [12.119.0-calc.3] - 2022-10-26
### Bug Fixes
- Fix streaming
- Fix gulpfile
- Fix caption in admin settings
- Fix: :fire: Remove meta implementation in routing for now
- Fix: recommended timeline
I doubt itll work, but...
๐Ÿ™
hail mairy
certified typeorm moment
im stuff
debug log
not a fan of js/ts
istg
missing parenthesis
postgres can kiss my ass
didnt need `::string[]` i think
hide caption button
Remove debug log
Clean up
no longer beta!
fix streaming
- Fix: caption in admin settings
Move splash below theme
Splash below theme
- Fix: :alembic: Attempt to fix routing
- Fix: :pencil2: Async typo
- Fix: :pencil2: Same typo as before...
- Fix: :lock: Remove timeline source if not logged in and guest tl isn't enabled
- Fix: :bug: No computed on declared var
- Fix: :bug: Allow timeline if logged in, loll
- Fix: :bug: timeline secured
- Fix: :bug: Remove header tabs if guest not enabled and not logged in
- Fix: :package: Fix yarn.lock
- Fix: :alembic: Try swiped-events
- Fix: :package: fix import
- Fix: :iphone: Fix for mobile
- Fix: :ambulance: No with dialog on load
- Fix: :bug: more mobile stuff
- Fix: :bug: fix avatar not showing up
- Fix: :alembic:
- Fix: :art: mount plyr with app
- Fix: :zap: Better import for plyr
- Fix: :lipstick: style
- Fix: :lipstick: style
- Fix: :bug: fix clicking on note content
- Fix: :alembic:
- Fix: :bug: do it right
- Fix: :bug: need MkA
- Fix: :bug: use router
- Fix: :bug: Prevent clicking on child elements of timeline posts
- Fix: :children_crossing: No more stupid details for replies
- Fix: :lock: Up multer to LTS as to avoid CVE-2022-24434
- Fix: :ambulance: Fix vue-plyr import
- Fix again
- Fix: :lipstick: fix buttons on entrance screen being squished on mobile
- Fix: :bug: only show on mobile, fix animation
- Fix: :bug: fix scroll
- Fix: :bug: fix again
- Fix: :bug: scroll
- Fix: :bug: fix videos having `<a>`
- Fix: :lipstick: only show post button on home tl
- Fix: :bug: ref
- Fix swipes?
- Fix: :bug: swipe left goes back a page
- Fix: :bug: swipe left on home wraps back
- Fix: :lipstick: consistent cw bg hover
- Fix: :bug: swipe bug
- Fix: :bug: fix scrolling bugs
- Fix
- Fix????
- Fix
- Fix: :zap: prerender prev and after slide
- Fix: :bug: show swiper
- Fix lints in folder.vue
- Fix pagination.vue lints
- Fix: volume sliders
Fixed a typo that made a required property be undefined.
- Fix screenshot size
- Fix: :lipstick: no blur on emoji picker --> blur safe by default
- Fix(client): fix syntax error of pages/follow.vue
- Fix: :ambulance: fix ref
- Fix: :bug: sync fixed
- Fix(server): ไป–ไบบใฎ้€š็Ÿฅใ‚’ๆ—ข่ชญใซใงใใ‚‹ๅฏ่ƒฝๆ€งใŒใ‚ใ‚‹ใฎใ‚’ไฟฎๆญฃ
- Fix
- Fix: :bug: Don't show tab title on mobile
- Fix: :bug: sync tab when getting last timeline
- Fix sync
- Fix: :rewind:
- Fix: :bug: fix header button positions on mobile
- Fix: :bug: Fix slide sync on initial timeline load
- Fix: :bug: Promper Info import
- Fix: :ambulance: tl not showing up
- Fix
- Fix: :bug: gay gay homosexual gay
- Fix: :bug: Show title on mobile if there's no tab buttons
- Fix: :bug: add script to pages view
- Fix
- Fix??
- Fix???
- Fix
- Fix motd
- Fix: :bug: motd
- Fix: :bug: No swiper on desktop
- Fix dup import
- Fix dup import
- Fix channels
- Fix clicking cw button on reply
- Fix: Profile bg blur respects user blur choice
- Fix
- Fix link
- Fix
- Fix
- Fix
- Fix
### Documentation
- Docs: :memo: Remove duplicate line
- Docs: :memo: npm -> yarn
- Docs: :memo: Add links
- Docs: :memo: Notable differences
- Docs: :memo: Customize instructions
- Docs: :memo: checksum behavior note
- Docs: :memo: emojis!
- Docs: :memo: planning join reasons
- Docs: :memo: warning for node 18.6.0
- Docs: :memo: Add swipe to WIP
- Docs: :memo:
- Docs: :memo: cl
- Docs: :memo: cl
- Docs: :memo: cl
- Docs: :memo: Mention groups
- Docs: ๐Ÿ“ cl
- Docs: ๐Ÿ“ Move add groups back to Implemented
- Docs: ๐Ÿ“ Docker instructions ๐Ÿ‹
- Docker-compose: replace misskey with calckey to fix example
- Docs :memo: ๐Ÿณ
### Features
- Feat: โœจ custom css/assets
typo
fix gulpfile
- Feat: โœจ togglable guest timeline
default false
rc 9
no async
welcome explore button to `/explore`
fix: :fire: Remove meta implementation in routing for now
- Feat: :bookmark: 12.118.1-calc release!
- Feat: show header with current user avatar on TL ([#9051](https://github.com/orhun/git-cliff/issues/9051))
* feat: show header with current user avatar on TL
* refactor(client): use displayMyAvatar prop instead of metadata
* refactor(client): prefer v-if to `display: none;`
- Feat: :bookmark: .1
- Feat: :sparkles: foundkey: add recollapsing quote notes
- Feat: :sparkles: Swipe through timelines on mobile
- Feat: :alembic: ripple effect
- Feat: :bookmark: .7
- Feat: :sparkles: Make mobile account avatar clickable
- Feat: :alembic: vue-plyr
- Feat: :bookmark: .5
- Feat: :lipstick: New note style
- Feat: :bookmark: .7
- Feat: :sparkles: Replies can be clicked too
- Feat: :lipstick: highlight hover replies
- Feat: :sparkles: More hover events!\
- Feat: :alembic: New post button on mobile
- Feat: :sparkles: Fade
- Feat: :sparkles: swipe thru notifs
- Feat: :alembic: try swiper
- Feat: :sparkles: pagination
- Feat: ๐Ÿ’„ style swiper
- Feat: :package: use swc
- Feat: :alembic: vsides
- Feat: โœจ improve pwa manifest
- Feat: :sparkles: Better tabs for mobile
- Feat: :sparkles: Swiper in notifs
- Feat: :alembic: Swiping in featured
- Feat: start work on vue-isyourpasswordsafe integration
- Feat: :sparkles: Attempt to add groups back!
- Feat: show ๐Ÿ“Ž in chats if only attachment
- Feat: :bookmark: v12.119.0
- Feat: โœจ Warning in control panel if there's update
- Feat: :sparkles: Add setting for swipe behavior
- Add console log
### Miscellaneous Tasks
- Chore: :loud_sound: Test logging
- Chore: :alembic: More debugging
- Chore: :bookmark: Bump to .3
- Update deps
- Chore: :package: Use proper misskey browser image resizer package
- Chore: :package: Add vue3-lottie
- Chore: :coffin: works
- Chore: :fire: remove fader
- Chore: ๐Ÿ’„ button height 3.5rem
- Chore: :loud_sound: log x swipe
- Chore(client): tweak loading display
- Update deps
- Chore: :arrow_up: Upgrade TypeORM
- Chore: :twisted_rightwards_arrows: Merge upstream
- Chore: :arrow_up: Upgrade Vite
- Chore: :arrow_up: Upgrade several deps
From yarn upgrade-interactive
- Chore: :bookmark: .16
- Chore: :twisted_rightwards_arrows: Merge upstream
- Chore(client): :art:
- Update deps
- Chore(sw): only proxies HTML requests ([#9070](https://github.com/orhun/git-cliff/issues/9070))
* chore(sw): only proxies HTML requests
ใ‚‚ใฏใ‚„HTMLใ˜ใ‚ƒใชใ•ใใ†ใชใƒชใ‚ฏใ‚จใ‚นใƒˆใซใฏSWใง้–ขไธŽใ—ใชใ„ใ‚ˆใ†ใซใ™ใ‚‹
ใ“ใ†ใ™ใ‚‹ใจใ„ใ‚ใ„ใ‚ใช้ขๅ€’ไบ‹ใŒ่งฃๆฑบใ™ใ‚‹ใฏใšโ€ฆใŸใถใ‚“
Resolve #9037
Resolve #9038
* align code style
* Update packages/sw/src/sw.ts
Co-authored-by: Acid Chicken (็กซ้…ธ้ถ) <root@acid-chicken.com>
Co-authored-by: syuilo <Syuilotan@yahoo.co.jp>
Co-authored-by: tamaina <tamaina@hotmail.co.jp>
Co-authored-by: Acid Chicken (็กซ้…ธ้ถ) <root@acid-chicken.com>
- Chore: :twisted_rightwards_arrows: Merge upstream to 12.119.0
- Chore: :twisted_rightwards_arrows: Merge upstream
- Chore: :package: Update lockfile
- Chore: :recycle: `about-misskey` -> `about-calckey`
- Chore: :loud_sound:
- Chore: spacing between icons in gallery index
- Chore: rm unused import
- Chore: :fire: rm tabs
- Chore: quote-button --> MkQuoteButton
### Refactor
- Enhance: add re-collapsing to quoted notes
- Refactor: :package: fuck them libs
- Refactor: :package: Use updated fork of vue-plyr
- Enhance(client): mobile twitter url can be used as widget ([#9057](https://github.com/orhun/git-cliff/issues/9057))
- Enhance(client): add html color-schema support
- Enhance(client): tweak clock
- Refactor(client): align filename to component name
- Enhance(client): improve analog-clock
- Refactor(client): use setup syntax
- Refactor(client): use setup syntax
- Refactor(client): use setup syntax
- Refactor(client): use setup syntax
- Refactor(client): use setup syntax
- Refactor(client): use setup syntax
- Refactor: :sparkles: Swiper, no swiping! :fox:
Swiper everywhere, attempt to sync to header bar
- Refactor(client): use setup syntax
- Refactor(client): use setup syntax
- Refactor(client): refactor file name and directory structure
- Refactor: :recycle: Use setup syntax for groups index
- Refactor: :sparkles: Move group actions to header bar
### Testing
- Test
- Test
- Testing
- Test
- Testtt
## [12.118.1-calc.rc.5.1] - 2022-08-09
### Bug Fixes
- Fix
- Fix again
- Fix fr on god no cap
- Fix lints
- Fix migration
- Fix againnn
- Fix duplicate keys
- Fix!!!!
- Fix: use new for throw error
Co-Authored-By: Acid Chicken (็กซ้…ธ้ถ) <root@acid-chicken.com>
- Fix spelling error
- Fix textarea not updating properly
fixes https://akkoma.dev/FoundKeyGang/FoundKey/issues/54
- Fix(client): cannot show some setting pages
Fix #9043
- Fix: copy visibility for renotes
- Fixxx
### Documentation
- Docs
### Features
- Feature: Client Preferences Registry ([#8511](https://github.com/orhun/git-cliff/issues/8511))
* Fix settings page
* nanka iroiro
* clean up
* clean up
* feature: Client Preferences Registry on the account
* add changelog
* ใ‚คใƒณใƒ‡ใƒƒใ‚ฏใ‚นใซๆˆปใฃใฆใ‚‚ใ‚ฟใ‚คใƒˆใƒซใŒๆฎ‹ใฃใฆใ—ใพใ†ใฎใ‚’ไฟฎๆญฃ
* fix createdAt -> updatedAt
* remove console.log
* ้ฉ็”จโ†’ใ“ใฎใƒ‡ใƒใ‚คใ‚นใซ้ฉ็”จ
* add wallpaper
* ใƒญใƒผใ‚ซใƒซใฎjsonใƒ•ใ‚กใ‚คใƒซใ‚’ไฟๅญ˜ใƒป่ชญใฟ่พผใฟใงใใ‚‹ใ‚ˆใ†ใซ
* clean up
* use apiWithDialog
* Update packages/client/src/pages/settings/preferences-registry.vue
Co-authored-by: Andreas Nedbal <github-bf215181b5140522137b3d4f6b73544a@desu.email>
* Update packages/client/src/pages/settings/preferences-registry.vue
Co-authored-by: Andreas Nedbal <github-bf215181b5140522137b3d4f6b73544a@desu.email>
* Update packages/client/src/pages/settings/preferences-registry.vue
Co-authored-by: Andreas Nedbal <github-bf215181b5140522137b3d4f6b73544a@desu.email>
* fix lint
* :v:
* change router
* nanka iroiro
* tweak
Co-authored-by: syuilo <Syuilotan@yahoo.co.jp>
Co-authored-by: Andreas Nedbal <github-bf215181b5140522137b3d4f6b73544a@desu.email>
- Feat(client): improve widget
- Add bullboard
- Add tes as dep, even if unused
### Miscellaneous Tasks
- Update deps
- Update preferences backup for calckey
- Chore(client): tweak scroll behavior in routing
### Performance
- Perf(client): use shallowRef as possible
### Refactor
- ๐ŸŽจ
- ๐ŸŽจ
- ๐ŸŽจ
- ๐ŸŽจ
- Refactor: welcome.setup.vue to composition api
- Enhance(client): improve clock widgets
- Enhance(client): improve clock widget
- Enhance(client): improve clock widget
- Enhance(client): improve clock widget
- Refactor
### Testing
- Test
- Test
- Test :(
- Testtt
- Testtt
- Test
## [12.118.0-calc.3.b4] - 2022-07-26
## [12.118.0-calc.b4] - 2022-07-26
### Bug Fixes
- Fix
- Fix search
- Fix(client): ใ‚ฟใ‚คใƒŸใƒณใ‚ฐใซใ‚ˆใฃใฆใฏ tag-cloud ใงใ‚จใƒฉใƒผใŒ็™บ็”Ÿใ™ใ‚‹ใฎใ‚’ไฟฎๆญฃ
- Fix(client): support v-if of select component
- Fix(client): fix some routings
- Fix(client): some fixes
- Fix: not logged in clients send correct header
- Fix(client): fix drawer menu style regression
- Fix(client): MiAuth page is broken
Fix #9026
- Fix: broken chats ([#8983](https://github.com/orhun/git-cliff/issues/8983))
* Fix broken chats
Co-authored-by: @ltlapy
* :art:
- Fix
- Fix style
- Fix
- Fixxxx
- Fix note button
- Fix html
- Fix import
- Fix
- Fix
### Features
- Add missing dependency
### Miscellaneous Tasks
- Chore(client): tweak radio component
- Chore(deps): bump terser from 5.9.0 to 5.14.2 ([#9024](https://github.com/orhun/git-cliff/issues/9024))
Bumps [terser](https://github.com/terser/terser) from 5.9.0 to 5.14.2.
- [Release notes](https://github.com/terser/terser/releases)
- [Changelog](https://github.com/terser/terser/blob/master/CHANGELOG.md)
- [Commits](https://github.com/terser/terser/commits)
---
updated-dependencies:
- dependency-name: terser
dependency-type: indirect
...
Signed-off-by: dependabot[bot] <support@github.com>
Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
- Chore(client): tweak theme select ui
- Chore: improve error message of boot
- Update tfjs
- Chore(deps): bump file-type from 17.1.2 to 17.1.3 in /packages/backend ([#9030](https://github.com/orhun/git-cliff/issues/9030))
Bumps [file-type](https://github.com/sindresorhus/file-type) from 17.1.2 to 17.1.3.
- [Release notes](https://github.com/sindresorhus/file-type/releases)
- [Commits](https://github.com/sindresorhus/file-type/compare/v17.1.2...v17.1.3)
---
updated-dependencies:
- dependency-name: file-type
dependency-type: direct:production
...
Signed-off-by: dependabot[bot] <support@github.com>
Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
- Chore(deps): bump undici from 5.5.1 to 5.8.0 in /packages/backend ([#9028](https://github.com/orhun/git-cliff/issues/9028))
Bumps [undici](https://github.com/nodejs/undici) from 5.5.1 to 5.8.0.
- [Release notes](https://github.com/nodejs/undici/releases)
- [Commits](https://github.com/nodejs/undici/compare/v5.5.1...v5.8.0)
---
updated-dependencies:
- dependency-name: undici
dependency-type: indirect
...
Signed-off-by: dependabot[bot] <support@github.com>
Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
- Chore(client): tweak style
- Chore(client): tweak ui
- Update deps
- Chore(client): tweak style
### Refactor
- Enhance(client): ใƒใ‚นใƒˆใ—ใŸใƒซใƒผใƒ†ใ‚ฃใƒณใ‚ฐใซๅฏพๅฟœ
- Refactor(client): :sparkles:
- Enhance(client): add some themes
- ๐ŸŽจ
- ๐ŸŽจ
- Refactor(client): refactor components
- Refactor pages/auth.form.vue to composition API
- Refactor: colours in queue chart
- Refactor queue chart to composition API
- Refactor pages/auth.form.vue to composition API
## [12.117.1.1-calc] - 2022-07-19
## [12.117.1-calc] - 2022-07-19
### Bug Fixes
- Fix(package): update swagger-jsdoc to version 1.9.0
https://greenkeeper.io/
- Fix(package): update @types/elasticsearch to version 5.0.11
https://greenkeeper.io/
- Fix(package): update @types/elasticsearch to version 5.0.12
https://greenkeeper.io/
- Fix(package): update body-parser to version 1.16.0
https://greenkeeper.io/
- Fix(package): update @types/express to version 4.0.35
https://greenkeeper.io/
- Fix(package): update file-type to version 4.1.0
https://greenkeeper.io/
- Fix(package): update whatwg-fetch to version 2.0.2
https://greenkeeper.io/
- Fix(package): update babel-preset-es2015 to version 6.22.0
https://greenkeeper.io/
- Fix(package): update babel-core to version 6.22.1
https://greenkeeper.io/
- Fix(package): update gulp-uglify to version 2.0.1
https://greenkeeper.io/
- Fix(package): update pug to version 2.0.0-beta8
https://greenkeeper.io/
- Fix(package): update browserify to version 14.0.0
https://greenkeeper.io/
- Fix(package): update multer to version 1.3.0
https://greenkeeper.io/
- Fix(package): update tslint to version 4.4.0
https://greenkeeper.io/
- Fix(package): update pug to version 2.0.0-beta9
https://greenkeeper.io/
- Fix(package): update tslint to version 4.4.2
https://greenkeeper.io/
- Fix(package): update express to version 4.14.1
https://greenkeeper.io/
- Fix(package): update riot to version 3.1.0
https://greenkeeper.io/
- Fix(package): update summaly to version 1.4.0
https://greenkeeper.io/
- Fix(package): update summaly to version 1.4.1
https://greenkeeper.io/
- Fix(package): update monk to version 3.1.4
https://greenkeeper.io/
- Fix(package): update velocity-animate to version 1.4.2
https://greenkeeper.io/
- Fix(package): update summaly to version 1.5.0
https://greenkeeper.io/
- Fix(package): update @types/multer to version 0.0.33
https://greenkeeper.io/
- Fix(package): update gulp-tslint to version 7.1.0
https://greenkeeper.io/
- Fix(package): update @types/mongodb to version 2.1.38
https://greenkeeper.io/
- Fix(package): update @types/mocha to version 2.2.39
https://greenkeeper.io/
- Fix(package): update @types/redis to version 0.12.35
https://greenkeeper.io/
- Fix(package): update riot-compiler to version 3.1.3
https://greenkeeper.io/
- Fix(package): update riot-compiler to version 3.1.4
https://greenkeeper.io/
- Fix(package): update riot to version 3.1.1
https://greenkeeper.io/
- Fix(package): update morgan to version 1.8.0
https://greenkeeper.io/
- Fix(package): update summaly to version 1.6.0
https://greenkeeper.io/
- Fix(package): update summaly to version 1.6.1
https://greenkeeper.io/
- Fix(package): update riot to version 3.2.0
https://greenkeeper.io/
- Fix(package): update js-yaml to version 3.8.0
https://greenkeeper.io/
- Fix(package): update bcryptjs to version 2.4.1
https://greenkeeper.io/
- Fix(package): update bcryptjs to version 2.4.2
https://greenkeeper.io/
- Fix(package): update bcryptjs to version 2.4.3
https://greenkeeper.io/
- Fix(package): update @types/chai-http to version 0.0.30
https://greenkeeper.io/
- Fix(package): update summaly to version 2.0.0
https://greenkeeper.io/
- Fix(package): update chart.js to version 2.5.0
https://greenkeeper.io/
- Fix(package): update typescript to version 2.1.6
https://greenkeeper.io/
- Fix(package): update @types/mongodb to version 2.1.39
https://greenkeeper.io/
- Fix(package): update riot to version 3.2.1
https://greenkeeper.io/
- Fix(package): update debug to version 2.6.1
https://greenkeeper.io/
- Fix(package): update @types/mongodb to version 2.1.40
https://greenkeeper.io/
- Fix(package): update body-parser to version 1.16.1
https://greenkeeper.io/
- Fix(package): update morgan to version 1.8.1
https://greenkeeper.io/
- Fix(package): update ratelimiter to version 2.2.0
https://greenkeeper.io/
- Fix(package): update monk to version 4.0.0
https://greenkeeper.io/
- Fix(package): update babel-core to version 6.23.1
https://greenkeeper.io/
- Fix(package): update browserify to version 14.1.0
https://greenkeeper.io/
- Fix(package): update mongodb to version 2.2.24
https://greenkeeper.io/
- Fix(package): update @types/request to version 0.0.40
https://greenkeeper.io/
- Fix(package): update gulp-typescript to version 3.1.5
https://greenkeeper.io/
- Fix(package): update @types/chai to version 3.4.35
https://greenkeeper.io/
- Fix(package): update @types/websocket to version 0.0.33
https://greenkeeper.io/
- Fix(package): update @types/body-parser to version 0.0.34
https://greenkeeper.io/
- Fix(package): update @types/redis to version 0.12.36
https://greenkeeper.io/
- Fix(package): update riot-compiler to version 3.2.0
https://greenkeeper.io/
- Fix(package): update riot to version 3.3.0
https://greenkeeper.io/
- Fix(package): update rimraf to version 2.6.0
https://greenkeeper.io/
- Fix(package): update riot-compiler to version 3.2.1
https://greenkeeper.io/
- Fix(package): update riot to version 3.3.1
https://greenkeeper.io/
- Fix(package): update serve-favicon to version 2.4.0
https://greenkeeper.io/
- Fix(package): update velocity-animate to version 1.4.3
https://greenkeeper.io/
- Fix(package): update swagger-jsdoc to version 1.9.2
https://greenkeeper.io/
- Fix(package): update inquirer to version 3.0.2
https://greenkeeper.io/
- Fix(package): update typescript to version 2.2.1
https://greenkeeper.io/
- Fix(package): update inquirer to version 3.0.3
https://greenkeeper.io/
- Fix(package): update inquirer to version 3.0.4
https://greenkeeper.io/
- Fix(package): update @types/mongodb to version 2.1.41
https://greenkeeper.io/
- Fix(package): update @types/webpack to version 2.2.7
https://greenkeeper.io/
- Fix(package): update rimraf to version 2.6.1
https://greenkeeper.io/
- Fix(package): update css-loader to version 0.26.2
https://greenkeeper.io/
- Fix(package): update cropperjs to version 1.0.0-beta.2
https://greenkeeper.io/
- Fix(package): update ratelimiter to version 3.0.2
https://greenkeeper.io/
- Fix(package): update inquirer to version 3.0.5
https://greenkeeper.io/
- Fix(package): update serve-favicon to version 2.4.1
https://greenkeeper.io/
- Fix(package): update tslint to version 4.5.1
https://greenkeeper.io/
- Fix
- Fix(package): update body-parser to version 1.17.0
https://greenkeeper.io/
- Fix
- Fix(package): update js-yaml to version 3.8.2
https://greenkeeper.io/
- Fix(package): update whatwg-fetch to version 2.0.3
https://greenkeeper.io/
- Fix(package): update inquirer to version 3.0.6
https://greenkeeper.io/
- Fix(package): update request to version 2.80.0
https://greenkeeper.io/
- Fix
- Fix(package): update cafy to version 1.0.1
https://greenkeeper.io/
- Fix(package): update riot to version 3.3.2
https://greenkeeper.io/
- Fix(package): update cafy to version 1.2.0
https://greenkeeper.io/
- Fix(package): update body-parser to version 1.17.1
https://greenkeeper.io/
- Fix(package): update @types/request to version 0.0.41
https://greenkeeper.io/
- Fix(package): update @types/webpack to version 2.2.8
https://greenkeeper.io/
- Fix(package): update string-replace-webpack-plugin to version 0.1.2
https://greenkeeper.io/
- Fix(package): update gulp-mocha to version 4.1.0
https://greenkeeper.io/
- Fix(package): update stylus-loader to version 2.5.1
https://greenkeeper.io/
- Fix(package): update @types/elasticsearch to version 5.0.13
https://greenkeeper.io/
- Fix(package): update @types/gm to version 1.17.30
https://greenkeeper.io/
- Fix(package): update css-loader to version 0.26.4
https://greenkeeper.io/
- Fix(package): update @types/gulp to version 4.0.0
https://greenkeeper.io/
- Fix(package): update ms to version 0.7.3
https://greenkeeper.io/
- Fix(package): update gulp-pug to version 3.3.0
https://greenkeeper.io/
- Fix(package): update @types/body-parser to version 1.16.0
https://greenkeeper.io/
- Fix(package): update @types/webpack to version 2.2.10
https://greenkeeper.io/
- Fix(package): update gulp-uglify to version 2.1.0
https://greenkeeper.io/
- Fix(package): update request to version 2.81.0
https://greenkeeper.io/
- Fix
- Fix(package): update css-loader to version 0.27.0
https://greenkeeper.io/
- Fix(package): update @types/webpack to version 2.2.11
https://greenkeeper.io/
- Fix(package): update css-loader to version 0.27.1
https://greenkeeper.io/
- Fix(package): update debug to version 2.6.2
https://greenkeeper.io/
- Fix(package): update @types/cors to version 2.8.1
https://greenkeeper.io/
- Fix(package): update @types/mocha to version 2.2.40
https://greenkeeper.io/
- Fix(package): update redis to version 2.7.0
https://greenkeeper.io/
- Fix(package): update css-loader to version 0.27.2
https://greenkeeper.io/
- Fix
- Fix(package): update css-loader to version 0.27.3
https://greenkeeper.io/
- Fix(package): update debug to version 2.6.3
https://greenkeeper.io/
- Fix(package): update redis to version 2.7.1
https://greenkeeper.io/
- Fix(package): update @types/gulp to version 4.0.1
https://greenkeeper.io/
- Fix(package): update @types/riot to version 2.6.2
https://greenkeeper.io/
- Fix(package): update @types/event-stream to version 3.3.31
https://greenkeeper.io/
- Fix(package): update @types/gulp to version 4.0.2
https://greenkeeper.io/
- Fix(package): update @types/gulp-mocha to version 0.0.30
https://greenkeeper.io/
- Fix(package): update @types/gulp-rename to version 0.0.32
https://greenkeeper.io/
- Fix(package): update @types/gulp-tslint to version 3.6.31
https://greenkeeper.io/
- Fix(package): update @types/gulp-uglify to version 0.0.30
https://greenkeeper.io/
- Fix(package): update @types/gulp-typescript to version 0.0.33
https://greenkeeper.io/
- Fix(package): update @types/gulp-util to version 3.0.31
https://greenkeeper.io/
- Fix(package): update gulp-typescript to version 3.1.6
https://greenkeeper.io/
- Fix(package): update mongodb to version 2.2.25
https://greenkeeper.io/
- Fix(package): update ms to version 1.0.0
https://greenkeeper.io/
- Fix(package): update gulp-uglify to version 2.1.1
https://greenkeeper.io/
- Fix(package): update gulp-uglify to version 2.1.2
https://greenkeeper.io/
- Fix(package): update ts-node to version 2.1.1
https://greenkeeper.io/
- Fix(package): update @types/body-parser to version 1.16.1
https://greenkeeper.io/
- Fix(package): update ts-node to version 3.0.1
https://greenkeeper.io/
- Fix(package): update @types/webpack to version 2.2.12
https://greenkeeper.io/
- Fix(package): update webpack to version 2.3.0
https://greenkeeper.io/
- Fix(package): update webpack to version 2.3.1
https://greenkeeper.io/
- Fix(package): update @types/request to version 0.0.42
https://greenkeeper.io/
- Fix(package): update mime-types to version 2.1.15
https://greenkeeper.io/
- Fix(package): update webpack to version 2.3.2
https://greenkeeper.io/
- Fix(package): update serve-favicon to version 2.4.2
https://greenkeeper.io/
- Fix(package): update gulp-imagemin to version 3.2.0
https://greenkeeper.io/
- Fix(package): update cropperjs to version 1.0.0-rc
https://greenkeeper.io/
- Fix(package): update animejs to version 2.0.2
https://greenkeeper.io/
- Fix(package): update riot to version 3.4.0
https://greenkeeper.io/
- Fix(package): update typescript to version 2.2.2
https://greenkeeper.io/
- Fix(package): update cors to version 2.8.2
https://greenkeeper.io/
- Fix(package): update cors to version 2.8.3
https://greenkeeper.io/
- Fix(package): update ratelimiter to version 3.0.3
https://greenkeeper.io/
- Fix
- Fix(package): update elasticsearch to version 13.0.0-rc1
https://greenkeeper.io/
- Fix(package): update js-yaml to version 3.8.3
https://greenkeeper.io/
- Fix(package): update accesses to version 2.1.1
https://greenkeeper.io/
- Fix(package): update accesses to version 2.2.0
https://greenkeeper.io/
- Fix(package): update accesses to version 2.3.0
https://greenkeeper.io/
- Fix(package): update accesses to version 2.4.0
https://greenkeeper.io/
- Fix(package): update accesses to version 2.4.1
https://greenkeeper.io/
- Fix(package): update riot to version 3.4.1
https://greenkeeper.io/
- Fix(package): update accesses to version 2.5.0
Closes #405
https://greenkeeper.io/
- Fix(package): update riot to version 3.4.2
https://greenkeeper.io/
- Fix(package): update file-type to version 4.2.0
https://greenkeeper.io/
- Fix(package): update mongodb to version 2.2.26
https://greenkeeper.io/
- Fix(package): update debug to version 2.6.4
https://greenkeeper.io/
- Fix(package): update elasticsearch to version 13.0.0
https://greenkeeper.io/
- Fix(package): update riot to version 3.4.3
https://greenkeeper.io/
- Fix(package): update typescript to version 2.3.1
https://greenkeeper.io/
- Fix(package): update debug to version 2.6.5
https://greenkeeper.io/
- Fix(package): update debug to version 2.6.6
https://greenkeeper.io/
- Fix(package): update download to version 6.0.0
https://greenkeeper.io/
- Fix(package): update typescript to version 2.3.2
https://greenkeeper.io/
- Fix(package): update cropperjs to version 1.0.0-rc.1
https://greenkeeper.io/
- Fix(package): update riot to version 3.4.4
https://greenkeeper.io/
- Fix(package): update pug to version 2.0.0-rc.1
https://greenkeeper.io/
- Fix(package): update ts-node to version 3.0.3
- Fix(package): update summaly to version 2.0.2
- Fix(package): update ts-node to version 3.0.4
- Fix(package): update file-type to version 4.3.0
- Fix(package): update summaly to version 2.0.3
- Fix(package): update js-yaml to version 3.8.4
- Fix(package): update elasticsearch to version 13.0.1
- Fix(package): update download to version 6.1.0
- Fix(package): update riot to version 3.5.0
- Fix(package): update cafy to version 2.4.0
- Fix(package): update ms to version 2.0.0
- Fix(package): update serve-favicon to version 2.4.3
- Fix(package): update debug to version 2.6.7
- Fix(package): update body-parser to version 1.17.2
- Fix(package): update debug to version 2.6.8
- Fix(package): update reconnecting-websocket to version 3.0.5
Closes #473
- Fix(package): update monk to version 4.1.0
- Fix(package): update monk to version 5.0.1
Closes #477
- Fix(package): update riot to version 3.5.1
- Fix(package): update monk to version 5.0.2
- Fix(package): update mongodb to version 2.2.27
- Fix(package): update typescript to version 2.3.3
- Fix(package): update download to version 6.2.0
- Fix(package): update morgan to version 1.8.2
- Fix(package): update download to version 6.2.2
- Fix(package): update cropperjs to version 1.0.0-rc.2
- Fix(package): update typescript to version 2.3.4
- Fix(package): update pictograph to version 2.0.1
- Fix(package): update pictograph to version 2.0.4
Closes #513
- Fix(package): update mongodb to version 2.2.28
- Fix(package): update pug to version 2.0.0-rc.2
- Fix(package): update monk to version 6.0.0
- Fix(package): update file-type to version 5.0.0
Closes #532
- Fix(package): update ts-node to version 3.0.5
- Fix(package): update ts-node to version 3.0.6
- Fix(package): update inquirer to version 3.1.0
- Fix(package): update riot to version 3.6.0
- Fix(package): update file-type to version 5.1.0
- Fix(package): update file-type to version 5.1.1
- Fix(package): update elasticsearch to version 13.1.1
- Fix(package): update uuid to version 3.1.0
- Fix spell
- Fix(package): update inquirer to version 3.1.1
- Fix(package): update download to version 6.2.3
- Fix(package): update mongodb to version 2.2.29
- Fix(package): update elasticsearch to version 13.2.0
Closes #570
- Fix(package): update ts-node to version 3.1.0
- Fix(package): update monk to version 6.0.1
- Fix(package): update riot to version 3.6.1
- Fix(package): update typescript to version 2.4.1
- Fix(package): update download to version 6.2.4
- Fix(package): update download to version 6.2.5
- Fix(package): update chalk to version 2.0.1
Closes #594
- Fix(package): update reconnecting-websocket to version 3.0.6
- Fix(package): update reconnecting-websocket to version 3.0.7
- Fix(package): update ts-node to version 3.2.0
- Fix(package): update cropperjs to version 1.0.0-rc.3
- Fix(package): update mongodb to version 2.2.30
- Fix(package): update js-yaml to version 3.9.0
- Fix(package): update inquirer to version 3.2.0
- Fix(package): update compression to version 1.7.0
- Fix(package): update cors to version 2.8.4
- Fix(package): update typescript to version 2.4.2
- Fix(package): update ts-node to version 3.2.1
- Fix(package): update inquirer to version 3.2.1
- Fix(package): update ts-node to version 3.3.0
Closes #642
- Fix(package): update recaptcha-promise to version 0.1.3
- Fix(package): update js-yaml to version 3.9.1
- Fix(package): update monk to version 6.0.3
- Fix(package): update pug to version 2.0.0-rc.3
- Fix(package): update chalk to version 2.1.0
- Fix(package): update redis to version 2.8.0
- Fix(package): update mongodb to version 2.2.31
- Fix(package): update debug to version 3.0.0
- Fix(package): update elasticsearch to version 13.3.1
Closes #673
- Fix(package): update crypto to version 1.0.1
Closes #682
- Fix(package): update reconnecting-websocket to version 3.1.1
Closes #686
- Fix(package): update file-type to version 6.1.0
- Fix(package): update inquirer to version 3.2.2
- Fix(package): update riot to version 3.6.2
- Fix(package): update reconnecting-websocket to version 3.2.0
- Fix(package): update riot to version 3.6.3
- Fix(package): update debug to version 3.0.1
- Fix(package): update reconnecting-websocket to version 3.2.1
- Fix(package): update inquirer to version 3.2.3
- Fix(package): update typescript to version 2.5.2
- Fix(package): update riot to version 3.7.0
- Fix(package): update cropperjs to version 1.0.0
- Fix(package): update pug to version 2.0.0-rc.4
- Fix(package): update body-parser to version 1.18.0
- Fix(package): update js-yaml to version 3.10.0
- Fix(package): update monk to version 6.0.4
- Fix(package): update rimraf to version 2.6.2
- Fix(package): update serve-favicon to version 2.4.4
- Fix(package): update body-parser to version 1.18.1
- Fix(package): update riot to version 3.7.1
- Fix
- Fix(package): update animejs to version 2.1.0
- Fix(package): update inquirer to version 3.3.0
- Fix(package): update cafy to version 3.0.0
- Fix(package): update request to version 2.82.0
- Fix(package): update body-parser to version 1.18.2
- Fix(package): update file-type to version 6.2.0
- Fix(package): update riot to version 3.7.2
- Fix(package): update reconnecting-websocket to version 3.2.2
- Fix(package): update animejs to version 2.2.0
- Fix(package): update serve-favicon to version 2.4.5
- Fix(package): update debug to version 3.1.0
- Fix(package): update typescript to version 2.5.3
- Fix(package): update morgan to version 1.9.0
- Fix(package): update request to version 2.83.0
- Fix(package): update compression to version 1.7.1
- Fix(package): update riot to version 3.7.3
- Fix(package): update monk to version 6.0.5
- Fix(package): update cropperjs to version 1.1.1
Closes #820
- Fix(package): update mongodb to version 2.2.33
Closes #826
- Fix(package): update file-type to version 7.2.0
Closes #821
- Fix(package): update cropperjs to version 1.1.2
- Fix(package): update websocket to version 1.0.25
- Fix(package): update cropperjs to version 1.1.3
- Fix(package): update chalk to version 2.3.0
Closes #833
- Fix(package): update typescript to version 2.6.1
- Fix(package): update cafy to version 3.1.1
Closes #857
- Fix(package): update riot to version 3.7.4
- Fix timeline
- Fix
- Fix
- Fix lint (automattic)
- Fix
- Fix
- Fix(package): update @types/elasticsearch to version 5.0.18
- Fix(package): update typescript to version 2.6.2
- Fix(package): update @types/chai to version 4.0.6
- Fix(package): update inquirer to version 4.0.1
- Fix(package): update eventemitter3 to version 3.0.0
- Fix(package): update uglifyjs-webpack-plugin to version 1.1.2
- Fix(package): update webpack to version 3.9.0
- Fix(package): update web-push to version 3.2.5
- Fix(package): update webpack to version 3.9.1
- Fix(package): update ms to version 2.1.1
Closes #958
- Fix(package): update awesome-typescript-loader to version 3.4.1
- Fix(package): update file-type to version 7.4.0
- Fix(package): update webpack to version 3.10.0
- Fix(package): update @types/chai to version 4.0.8
Closes #963
- Fix(package): update @types/elasticsearch to version 5.0.19
- Fix(package): update @types/node to version 8.0.57
Closes #964
- Fix(package): update @types/redis to version 2.8.2
- Fix(package): update @fortawesome/fontawesome to version 1.0.1
- Fix(package): update @fortawesome/fontawesome-free-solid to version 5.0.1
- Fix(package): update @fortawesome/fontawesome-free-regular to version 5.0.1
- Fix(package): update @fortawesome/fontawesome-free-brands to version 5.0.1
- Fix(package): update pictograph to version 2.1.5
Closes #979
- Fix(package): update @types/mongodb to version 2.2.17
- Fix(package): update @types/node to version 8.0.58
- Fix(package): update @types/chai to version 4.0.10
Closes #988
- Fix(package): update @types/request to version 2.0.9
- Fix(package): update @types/node to version 8.5.0
- Fix(package): update @types/redis to version 2.8.3
- Fix(package): update @types/inquirer to version 0.0.36
- Fix(package): update @types/node to version 8.5.1
- Fix(package): update uglifyjs-webpack-plugin to version 1.1.3
- Fix(package): update style-loader to version 0.19.1
- Fix(package): update uglifyjs-webpack-plugin to version 1.1.4
- Fix(package): update cropperjs to version 1.2.1
Closes #1006
- Fix(package): update riot-tag-loader to version 1.1.0
- Fix(package): update ts-node to version 4.1.0
Closes #985
- Fix(package): update riot-tag-loader to version 2.0.0
Closes #1042
- Fix(package): update gulp-htmlmin to version 4.0.0
- Fix(package): update mongodb to version 3.0.1
Closes #1046
- Fix(package): update riot-tag-loader to version 2.0.1
- Fix(package): update uglifyjs-webpack-plugin to version 1.1.5
- Fix(package): update qrcode to version 1.0.1
- Fix(package): update gm to version 1.23.1
- Fix(package): update riot to version 3.8.0
- Fix(package): update riot to version 3.8.1
- Fix(package): update qrcode to version 1.2.0
Closes #1053
- Fix(package): update riot-tag-loader to version 2.0.2
- Fix(package): update gulp-imagemin to version 4.1.0
- Fix(package): update css-loader to version 0.28.10
- Fix(package): update vue-js-modal to version 1.3.12
- Fix(package): update mongodb to version 3.0.3
- Fix(package): update web-push to version 3.3.0
- Fix(package): update webpack to version 4.0.0
- Fix(package): update @types/compression to version 0.0.36
- Fix(package): update @types/inquirer to version 0.0.38
- Fix(package): update @types/mongodb to version 3.0.8
- Fix(package): update @types/webpack to version 4.1.1
- Fix(package): update css-loader to version 0.28.11
- Fix(package): update elasticsearch to version 14.2.1
- Fix(package): update eslint to version 4.19.0
- Fix(package): update license-checker to version 17.0.0
- Fix(package): update ws to version 5.1.0
- Fix(package): update html-minifier to version 3.5.12
- Fix(package): update pug to version 2.0.2
- Fix(package): update license-checker to version 18.0.0
- Fix(package): update is-url to version 1.2.3
- Fix(package): update webpack to version 4.2.0
- Fix(package): update pug to version 2.0.3
- Fix(package): update eslint to version 4.19.1
- Fix(package): update eslint-plugin-vue to version 4.4.0
- Fix(package): update chai-http to version 4.0.0
- Fix(package): update is-root to version 2.0.0
- Fix(package): update webpack-cli to version 2.0.13
- Fix(package): update gulp-typescript to version 4.0.2
- Fix(package): update element-ui to version 2.3.0
- Fix(package): update element-ui to version 2.3.2
Closes #1330
- Fix(package): update @types/js-yaml to version 3.11.1
- Fix(package): update html-minifier to version 3.5.13
- Fix(package): update bootstrap-vue to version 2.0.0-rc.4
Closes #1349
- Fix(package): update jsdom to version 11.7.0
- Fix(package): update bootstrap-vue to version 2.0.0-rc.6
Closes #1367
- Fix(package): update ws to version 5.1.1
- Fix(package): update @types/node to version 9.6.2
- Fix(package): update @types/inquirer to version 0.0.41
- Fix(package): update element-ui to version 2.3.3
- Fix(package): update webpack to version 4.5.0
- Fix(package): update object-assign-deep to version 0.4.0
- Fix(package): update webpack-cli to version 2.0.14
- Fix(package): update @types/mongodb to version 3.0.10
- Fix(package): update vue-loader to version 15.0.0-rc.1
- Fix(package): update html-minifier to version 3.5.14
- Fix(package): update gulp-pug to version 4.0.0
- Fix(package): update @types/mongodb to version 3.0.11
- Fix(package): update mongodb to version 3.0.6
- Fix(package): update @types/mongodb to version 3.0.12
- Fix(package): update @types/node to version 9.6.4
Closes #1444
- Fixed english translation
- Fixed english translation
- Fixed translate.en.md
- Fix(package): update mongodb to version 3.0.7
- Fix(package): update @types/mongodb to version 3.0.15
Closes #1513
- Fix(package): update style-loader to version 0.21.0
- Fix typo
- Fix typo
Signed-off-by: Marcin Mikoล‚ajczak <me@m4sk.in>
- Fix #1428
- Fix typo
Signed-off-by: Marcin Mikoล‚ajczak <me@m4sk.in>
- Fix typo
- Fix: validate post's text on mobile client.
- Fix: validate post's text with Ctrl+Enter on PC.
- Fix: when text is null, bug can pass validation.
fixed. (maybe?)
- Fix: "or" operator.
- Fix #1726
- Fix
- Fix(package): update ts-node to version 6.1.2
- Fix(package): update web-push to version 3.3.2
- Fix(package): update @types/koa-bodyparser to version 5.0.0
- Fix(package): update @types/koa-router to version 7.0.29
- Fix(package): update @types/mocha to version 5.2.3
- Fix(package): update @types/webpack to version 4.4.2
- Fix(package): update @types/koa-router to version 7.0.30
- Fix(package): update ratelimiter to version 3.1.0
- Fix(package): update ts-node to version 7.0.0
Closes #1765
- Fix(package): update @types/node to version 10.3.5
- Fix(package): update hard-source-webpack-plugin to version 0.9.0
- Fix(package): update eslint to version 5.0.0
- Fix(package): update ws to version 5.2.1
- Fix(package): update webpack to version 4.12.1
- Fix(package): update html-minifier to version 3.5.17
- Fix(package): update @types/node to version 10.3.6
- Fix(package): update @types/webpack to version 4.4.3
- Fix(package): update eslint to version 5.0.1
- Fix(package): update element-ui to version 2.4.2
- Fix(package): update uuid to version 3.3.0
- Fix(package): update webpack to version 4.12.2
- Fix(package): update mongodb to version 3.1.0
- Fix(package): update typescript-eslint-parser to version 16.0.1
- Fix(package): update @types/mongodb to version 3.0.22
- Fix(package): update @types/node to version 10.5.0
- Fix(package): update @types/webpack to version 4.4.4
- Fix(package): update uuid to version 3.3.2
- Fix(package): update @types/mongodb to version 3.0.23
- Fix(package): update @types/node to version 10.5.1
- Fix(package): update webpack to version 4.14.0
Closes #1818
- Fix(package): update @types/mongodb to version 3.1.0
- Fix(package): update hard-source-webpack-plugin to version 0.10.0
- Fix(package): update vue-js-modal to version 1.3.16
- Fix(package): update hard-source-webpack-plugin to version 0.10.1
- Fix(package): update element-ui to version 2.4.3
- Fix(package): update html-minifier to version 3.5.18
- Fix(package): update elasticsearch to version 15.1.0
- Fix(package): update elasticsearch to version 15.1.1
- Fix(package): update @types/js-yaml to version 3.11.2
- Fix(package): update @types/mongodb to version 3.1.1
- Fix(package): update @types/webpack to version 4.4.5
- Fix(package): update webpack to version 4.15.0
- Fix(package): update node-sass to version 4.9.1
- Fix(package): update webpack to version 4.15.1
- Fix(package): update mongodb to version 3.1.1
- Fix(package): update @types/node to version 10.5.2
- Fix(package): update css-loader to version 1.0.0
- Fix(package): update hard-source-webpack-plugin to version 0.11.0
Closes #1861
- Fix(package): update node-sass to version 4.9.2
- Fix(package): update file-type to version 8.1.0
- Fix(package): update @types/koa-bodyparser to version 5.0.1
- Fix(package): update webpack to version 4.16.0
- Fix(package): update @koa/cors to version 2.2.2
- Fix(package): update ws to version 5.2.2
- Fix(package): update hard-source-webpack-plugin to version 0.11.1
- Fix(package): update element-ui to version 2.4.4
- Fix(package): update html-minifier to version 3.5.19
- Fix(package): update @types/elasticsearch to version 5.0.25
- Fix(package): update @types/webpack to version 4.4.6
- Fix(package): update eslint-plugin-vue to version 4.6.0
- Fix(package): update eslint-plugin-vue to version 4.7.0
- Fix(package): update webpack to version 4.16.1
- Fix(package): update @types/webpack to version 4.4.7
- Fix(package): update vue-loader to version 15.2.5
- Fix(package): update vue-loader to version 15.2.6
- Fix(package): update webpack-cli to version 3.1.0
- Fix(package): update swagger-jsdoc to version 1.10.2
Closes #1924
- Fix(package): update emojilib to version 2.3.0
- Fix(package): update @types/mongodb to version 3.1.2
- Fix(package): update ratelimiter to version 3.2.0
- Fix(package): update ws to version 6.0.0
- Fix(package): update hard-source-webpack-plugin to version 0.11.2
- Fix(package): update swagger-jsdoc to version 1.10.3
- Fix(package): update webpack to version 4.16.2
- Fix(package): update gulp-rename to version 1.4.0
- Fix(package): update @types/webpack to version 4.4.8
- Fix(package): update eslint-plugin-vue to version 4.7.1
- Fix(package): update @types/node to version 10.5.3
- Fix(package): update gulp-uglify to version 3.0.1
- Fix(package): update element-ui to version 2.4.5
- Fix(package): update typescript-eslint-parser to version 17.0.0
- Fix(package): update typescript-eslint-parser to version 17.0.1
- Fix(package): update jsdom to version 11.12.0
- Fix: critical memory leak.
- Fix(package): update webpack to version 4.16.3
- Fix(package): update @types/koa-router to version 7.0.31
- Fix(package): update @types/node to version 10.5.4
- Fix(package): update hard-source-webpack-plugin to version 0.12.0
- Fix(package): update @types/koa__cors to version 2.2.3
- Fix(package): update qrcode to version 1.2.2
- Fix(package): update @types/node to version 10.5.5
- Fix(package): update sass-loader to version 7.1.0
- Fix(package): update vue-template-compiler to version 2.5.17
- Fix(package): update vue to version 2.5.17
- Fix(package): update @types/webpack to version 4.4.9
- Fix(package): update @types/mongodb to version 3.1.3
- Fix(package): update webpack to version 4.16.4
- Fix(package): update systeminformation to version 3.42.6
Closes #2076
- Fix(package): update systeminformation to version 3.42.8
- Fix(package): update commander to version 2.17.0
- Fix(package): update @types/node to version 10.5.6
- Fix(package): update webpack to version 4.16.5
- Fix(package): update typescript-eslint-parser to version 18.0.0
- Fix(package): update @types/node to version 10.5.7
- Fix(package): update vue-loader to version 15.2.7
- Fix(package): update commander to version 2.17.1
- Fix(package): update style-loader to version 0.22.0
- Fix(package): update vue-loader to version 15.3.0
- Fix(package): update systeminformation to version 3.42.9
- Fix(package): update style-loader to version 0.22.1
- Fix(package): update summaly to version 2.1.0 ([#2132](https://github.com/orhun/git-cliff/issues/2132))
- Fix(package): update node-sass to version 4.9.3 ([#2131](https://github.com/orhun/git-cliff/issues/2131))
- Fix(package): update summaly to version 2.1.1 ([#2135](https://github.com/orhun/git-cliff/issues/2135))
- Fix(package): update element-ui to version 2.4.6
- Fix(package): update file-type to version 9.0.0
- Fix(package): update summaly to version 2.1.2 ([#2149](https://github.com/orhun/git-cliff/issues/2149))
- Fix(package): update request to version 2.88.0 ([#2151](https://github.com/orhun/git-cliff/issues/2151))
- Fix(package): update @types/node to version 10.5.8 ([#2152](https://github.com/orhun/git-cliff/issues/2152))
- Fix(package): update ts-node to version 7.0.1
- Fix(package): update vue-js-modal to version 1.3.17
- Fix(package): update parse5 to version 5.1.0
- Fix(package): update mongodb to version 3.1.2
- Fix(package): update vue-style-loader to version 4.1.2
- Fix(package): update mon