#23 Recipe structure not recognized

Closed
opened 4 months ago by Moini · 6 comments
Moini commented 4 months ago

Cookbook app from FDroid version 1.4.0 on LineageOS 16 (Android 9)

Recipe files are synced to device.

Recipe with Umlaut in folder name does not show up (compare screenshots).

It's the only reason I can think of, but might not be true. Please let me know if you need more information to reproduce the issue.

Cookbook app from FDroid version 1.4.0 on LineageOS 16 (Android 9) Recipe files are synced to device. Recipe with Umlaut in folder name does not show up (compare screenshots). It's the only reason I can think of, but might not be true. Please let me know if you need more information to reproduce the issue.
Moini commented 4 months ago
Poster

(Could also be the category name with the accent, of course)

(Could also be the category name with the accent, of course)
MicMun commented 4 months ago
Owner

Can you upload the json file of the missing recipe?
I don't think that accent or Umlaut should be an issue.
Most of the time there is a missing field in the json file or any other reason in the data to parse.

Can you upload the json file of the missing recipe? I don't think that accent or Umlaut should be an issue. Most of the time there is a missing field in the json file or any other reason in the data to parse.
Moini commented 4 months ago
Poster

Yes, of course:

Yes, of course:
MicMun added the
bug
label 4 months ago
MicMun commented 4 months ago
Owner

Is this an imported recipe or self created?
The problem is in recipeInstructions: the specification says that is an array ["", "", ...].
In your recipe it is an json object with keys and values, my parser cannot transform that in a list.

Is this an imported recipe or self created? The problem is in recipeInstructions: the specification says that is an array ["", "", ...]. In your recipe it is an json object with keys and values, my parser cannot transform that in a list.
Moini commented 4 months ago
Poster

I've created it using the cookbook nextcloud app. (so, on my personal nextcloud web site)

I've created it using the cookbook nextcloud app. (so, on my personal nextcloud web site)
Moini changed title from Recipes with Umlaut not loaded to Recipe structure not recognized 4 months ago
MicMun added this to the 2.0.0 milestone 3 months ago
MicMun self-assigned this 3 months ago
MicMun closed this issue 2 weeks ago
Moini commented 5 days ago
Poster

Confirmed, works now. Lots of new issues, though :/

Confirmed, works now. Lots of new issues, though :/
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.