#17 Refreshing list of recipes behaves randomly

Closed
opened 7 months ago by cianuro · 3 comments
cianuro commented 7 months ago

First off, I'd like to take a moment to thank you for this app! It looks promising, and the lack of such an app was the only thing preventing me from moving to Nextcloud Cookbook, so now that it exists, I'm taking the time to migrate my recipes to this format. So, thanks a lot!

Now, on with the report!

On first boot, the list of recipes takes a while to load (around 15 seconds for a list of 6 recipes, 5 of them with photo), but works flawlessly.

After this, however, refreshing the list (or choosing a reciping and going back to main screen), results in a very random behaviour. These are some of the things that can happen:

  • No recipe is shown
  • Only 3 recipes are shown
  • All recipes are shown, but duplicated
  • Only 1 recipe is shown
  • Only two recipes are shown, one of them duplicated
  • All recipes are shown, but some of them appear 3 times

Finally, after a while, it seems to stabilize and returns to the expected behaviour, just one entry per recipe.

First off, I'd like to take a moment to thank you for this app! It looks promising, and the lack of such an app was the only thing preventing me from moving to Nextcloud Cookbook, so now that it exists, I'm taking the time to migrate my recipes to this format. So, thanks a lot! Now, on with the report! On first boot, the list of recipes takes a while to load (around 15 seconds for a list of 6 recipes, 5 of them with photo), but works flawlessly. After this, however, refreshing the list (or choosing a reciping and going back to main screen), results in a very random behaviour. These are some of the things that can happen: * No recipe is shown * Only 3 recipes are shown * All recipes are shown, but duplicated * Only 1 recipe is shown * Only two recipes are shown, one of them duplicated * All recipes are shown, but some of them appear 3 times Finally, after a while, it seems to stabilize and returns to the expected behaviour, just one entry per recipe.
MicMun commented 7 months ago
Owner

The reading of the files is not optimal.
I work on an optimization and to fix this issues.

The reading of the files is not optimal. I work on an optimization and to fix this issues.
ftrcat commented 6 months ago

I totally agree with @cianuro. I use the Nextcloud App since I installed you app, and I've actually started cooking stuff that I saved. So thank you so much, @MicMun! Never has any app made me so happy like this one.

Regarding the issue:
I just want to add that on my phone I can replicate the following behaviour:

  • Select a category of recipes
  • Select one of those recipes
  • Press the back button to go back to list of recipes
  • The category is still shown in the title bar, but the list refreshes and shows all recipes

Also:

  • Select a category
  • Refresh by scrolling too far upwards
  • Selected category is still shown in title bar, but list refreshes and shows all recipes

This is a little different from what @cianuro observed, but I guess it's related.

I totally agree with @cianuro. I use the Nextcloud App since I installed you app, and I've actually started cooking stuff that I saved. So thank you so much, @MicMun! Never has any app made me so happy like this one. Regarding the issue: I just want to add that on my phone I can replicate the following behaviour: * Select a category of recipes * Select one of those recipes * Press the back button to go back to list of recipes * The category is still shown in the title bar, but the list refreshes and shows *all* recipes Also: * Select a category * Refresh by scrolling too far upwards * Selected category is still shown in title bar, but list refreshes and shows *all* recipes This is a little different from what @cianuro observed, but I guess it's related.
MicMun added the
bug
label 6 months ago
MicMun added this to the 2.0.0 milestone 6 months ago
MicMun self-assigned this 6 months ago
MicMun commented 6 months ago
Owner

This is on my todo list for version 2, there will be a rewrite to handle this in a better way.
I try to finish this until end of the year.
It is not easy to solve this faster.

This is on my todo list for version 2, there will be a rewrite to handle this in a better way. I try to finish this until end of the year. It is not easy to solve this faster.
MicMun closed this issue 1 week ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.