Browse Source

gradle: We only need to exclude xpp3_min

Since xpp3 is only declared as 'implementation' in
smack-xmlparser-xpp3, whereas xpp3_min is declared as 'api'. This
means that only xpp3_min is pulled in by the build system, but as it
is already provided by Android, we need to exclude it again.
pull/20/head
Florian Schmaus 1 month ago
parent
commit
f6b4341a30
1 changed files with 0 additions and 1 deletions
  1. +0
    -1
      build.gradle

+ 0
- 1
build.gradle View File

@@ -37,7 +37,6 @@ allprojects {
// Exclude XmlPullParser from Smack dependencies, as its now provided by Android
// https://stackoverflow.com/questions/48488563/gradle-xpp3-error/48746294#48746294
all {
exclude group: 'xpp3', module: 'xpp3'
exclude group: 'xpp3', module: 'xpp3_min'
}
}

Loading…
Cancel
Save