float-nix-flake-package-exa.../flake.nix

31 lines
832 B
Nix

{
description = "minimalist Configurable Homelab Start Page";
inputs = {
nixpkgs.url = "nixpkgs/nixos-22.05";
};
outputs = {nixpkgs, ...}: let
# you can also put any architecture you want to support here
# i.e. aarch64-darwin for never M1/2 macbooks
system = "x86_64-linux";
pname = "float";
in {
packages.${system} = let
pkgs = import nixpkgs {inherit system;}; # this gives us access to nixpkgs as we are used to
in {
default = pkgs.buildGoModule {
name = pname;
src = pkgs.fetchFromGitHub {
owner = "aaqaishtyaq";
repo = pname;
rev = "v0.0.3";
sha256 = "sha256-3gMP9VjC8+u41gvzT45LflqZ4uk5+tObBtlJO5SCjwQ=";
};
vendorSha256 = "sha256-1TyFfRL6HTOa+M4CEcHeiReRcPlPNKMneq2AVXS0kX0=";
};
};
};
}