Docker #2

Closed
opened 10 months ago by esmailelbob · 27 comments

Hi, I'm intrested to host your app but I wonder if you plan to add docker-compose support??

Hi, I'm intrested to host your app but I wonder if you plan to add docker-compose support??
Owner

Sure!
Would you like docker support for the frontend/backend or both ?

Sure! Would you like docker support for the frontend/backend or both ?
Poster

I see it does use piped as backend, Am I right? if so then I want front end only

I see it does use piped as backend, Am I right? if so then I want front end only
Owner

Well yes, for most api requests it uses piped-backend.

However, Simce NewPipeExtractor does not fully support YouTube music I have to occasionally rely on Hyperpipe/hyperpipe-backend to fill in :)

I will be adding docker support for the frontend soon.

Well yes, for most api requests it uses piped-backend. However, Simce `NewPipeExtractor` does not fully support YouTube music I have to occasionally rely on [Hyperpipe/hyperpipe-backend](https://codeberg.org/Hyperpipe/hyperpipe-backend) to fill in :) I will be adding docker support for the frontend soon.
Poster

Well, I think both then if it's okay with you

Well, I think both then if it's okay with you
Owner

Absolutely, I will be adding docker support for the backend too.

But please do give me a little time as I am a little busy this week

Absolutely, I will be adding docker support for the backend too. But please do give me a little time as I am a little busy this week
snematoda self-assigned this 10 months ago
snematoda added the
Kind: Enhancement
label 10 months ago
Poster

Yeah sure I will wait and another off-topic question, why my piped do not play nicely xD

Yeah sure I will wait and another off-topic question, why my piped do not play nicely xD
Owner

XD I will have to look into that

XD I will have to look into that
Poster

Alirght my instance is piped.esmailelbob.xyz

so maybe change it in hyperpipe or let me know if you want my piped logs

Alirght my instance is piped.esmailelbob.xyz so maybe change it in hyperpipe or let me know if you want my piped logs
Owner

Docker support has been added for the frontend.

I have used docker only a couple of times before, so please let me know if it doesn't work as intended

Docker support has been added for the frontend. I have used docker only a couple of times before, so please let me know if it doesn't work as intended
snematoda closed this issue 10 months ago
snematoda reopened this issue 10 months ago
Poster

Good news it works sad news my piped still do not play nice with it

You can add my instance now https://hyperpipe.esmailelbob.xyz

Good news it works sad news my piped still do not play nice with it You can add my instance now https://hyperpipe.esmailelbob.xyz
Poster

So any hope I noticed my piped and some other instances do not play nice (outside official one) so why

Hmm weird when hyperpipe request something it sends 500 (internal server error) but when I open my piped it works fine so I think something bad happenes when both talk but if that the case why it plays nice with official piped? I'm confused xD

nginx            | 2022-07-29T20:35:10.373476244Z 172.20.0.1 - - [29/Jul/2022:20:35:10 +0000] "GET /playlists/RDCLAK5uy_kmK1aMjb7sJ6eWV95Co02JwJJmdi0z05M HTTP/1.0" 200 30342 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-"
nginx            | 2022-07-29T20:35:10.418295322Z 172.20.0.1 - - [29/Jul/2022:20:35:10 +0000] "GET /channel/UCE_M8A5yxnLfW0KghEeajjw HTTP/1.0" 200 17205 "-" "Uptime-Kuma/1.17.1" "-"
nginx            | 2022-07-29T20:35:13.489166931Z 172.20.0.1 - - [29/Jul/2022:20:35:13 +0000] "GET /streams/UO4qGXD-O1o HTTP/1.0" 500 1189 "-" "python-requests/2.27.1" "-"
nginx            | 2022-07-29T20:35:13.545384561Z 172.20.0.1 - - [29/Jul/2022:20:35:13 +0000] "GET /streams/4tBlW-F0Nv8 HTTP/1.0" 200 37816 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-"
nginx            | 2022-07-29T20:35:14.519500633Z 172.20.0.1 - - [29/Jul/2022:20:35:14 +0000] "GET /streams/Vo4GmHxZzZo HTTP/1.0" 500 1187 "-" "python-requests/2.27.1" "-"
So any hope I noticed my piped and some other instances do not play nice (outside official one) so why Hmm weird when hyperpipe request something it sends 500 (internal server error) but when I open my piped it works fine so I think something bad happenes when both talk but if that the case why it plays nice with official piped? I'm confused xD ``` nginx | 2022-07-29T20:35:10.373476244Z 172.20.0.1 - - [29/Jul/2022:20:35:10 +0000] "GET /playlists/RDCLAK5uy_kmK1aMjb7sJ6eWV95Co02JwJJmdi0z05M HTTP/1.0" 200 30342 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-" nginx | 2022-07-29T20:35:10.418295322Z 172.20.0.1 - - [29/Jul/2022:20:35:10 +0000] "GET /channel/UCE_M8A5yxnLfW0KghEeajjw HTTP/1.0" 200 17205 "-" "Uptime-Kuma/1.17.1" "-" nginx | 2022-07-29T20:35:13.489166931Z 172.20.0.1 - - [29/Jul/2022:20:35:13 +0000] "GET /streams/UO4qGXD-O1o HTTP/1.0" 500 1189 "-" "python-requests/2.27.1" "-" nginx | 2022-07-29T20:35:13.545384561Z 172.20.0.1 - - [29/Jul/2022:20:35:13 +0000] "GET /streams/4tBlW-F0Nv8 HTTP/1.0" 200 37816 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-" nginx | 2022-07-29T20:35:14.519500633Z 172.20.0.1 - - [29/Jul/2022:20:35:14 +0000] "GET /streams/Vo4GmHxZzZo HTTP/1.0" 500 1187 "-" "python-requests/2.27.1" "-" ```
Owner

I did look into this issue and it seems like the hls manifests returned an error code 500 when I tried, I am not sure about the reason for this.

But, After looking at how pioed's official frontend plays videos, it seems that using mpeg-dash is the right move to make.

I have already started out with adding dash support, hopefully it would be solved by then

https://codeberg.org/Hyperpipe/Hyperpipe/src/branch/main/src/scripts/dash.js

I did look into this issue and it seems like the hls manifests returned an error code 500 when I tried, I am not sure about the reason for this. But, After looking at how pioed's official frontend plays videos, it seems that using `mpeg-dash` is the right move to make. I have already started out with adding dash support, hopefully it would be solved by then https://codeberg.org/Hyperpipe/Hyperpipe/src/branch/main/src/scripts/dash.js
Poster

Did I miss something? I tried to git pull and rebuild docker but seems nothing have changed

Did I miss something? I tried to git pull and rebuild docker but seems nothing have changed
Poster

Okay I no longer see 500 status code but still I can't play songs :(

nginx            | 2022-07-30T06:48:25.578606442Z 192.168.208.1 - - [30/Jul/2022:06:48:25 +0000] "GET /streams/USb5JBhZed0 HTTP/1.0" 200 35812 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-"
nginx            | 2022-07-30T06:48:59.085665102Z 192.168.208.1 - - [30/Jul/2022:06:48:59 +0000] "GET /channel/UCE_M8A5yxnLfW0KghEeajjw HTTP/1.0" 200 17221 "-" "Uptime-Kuma/1.17.1" "-"
nginx            | 2022-07-30T06:49:15.915337375Z 192.168.208.1 - - [30/Jul/2022:06:49:15 +0000] "GET /search?q=ed+sheeran&filter=music_songs HTTP/1.0" 200 10416 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-"
nginx            | 2022-07-30T06:49:28.346115146Z 192.168.208.1 - - [30/Jul/2022:06:49:28 +0000] "GET /streams/xTvyyoF_LZY HTTP/1.0" 200 36801 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-"
Okay I no longer see 500 status code but still I can't play songs :( ``` nginx | 2022-07-30T06:48:25.578606442Z 192.168.208.1 - - [30/Jul/2022:06:48:25 +0000] "GET /streams/USb5JBhZed0 HTTP/1.0" 200 35812 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-" nginx | 2022-07-30T06:48:59.085665102Z 192.168.208.1 - - [30/Jul/2022:06:48:59 +0000] "GET /channel/UCE_M8A5yxnLfW0KghEeajjw HTTP/1.0" 200 17221 "-" "Uptime-Kuma/1.17.1" "-" nginx | 2022-07-30T06:49:15.915337375Z 192.168.208.1 - - [30/Jul/2022:06:49:15 +0000] "GET /search?q=ed+sheeran&filter=music_songs HTTP/1.0" 200 10416 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-" nginx | 2022-07-30T06:49:28.346115146Z 192.168.208.1 - - [30/Jul/2022:06:49:28 +0000] "GET /streams/xTvyyoF_LZY HTTP/1.0" 200 36801 "https://hyperpipe.esmailelbob.xyz/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.53 Safari/537.36" "-" ```
Owner

Yes ... I am working on fixing the issue, But I need time to figure out what exactly the issue is :)

Yes ... I am working on fixing the issue, But I need time to figure out what exactly the issue is :)
Poster

Oh...that what you meant from "hopefully it would be solved by then"

I thought you meant you fixed it, my mistake sorry xd

Well, good news is no more 500 status code and if you need my logs of hyperpipe or piped, I would love to help!

Oh...that what you meant from "hopefully it would be solved by then" I thought you meant you fixed it, my mistake sorry xd Well, good news is no more `500` status code and if you need my logs of hyperpipe or piped, I would love to help!
Owner

Should be fixed now ;)

Oh...that what you meant from "hopefully it would be solved by then"

I thought you meant you fixed it, my mistake sorry xd

Well, good news is no more 500 status code and if you need my logs of hyperpipe or piped, I would love to help!

Should be fixed now ;)
Could you just confirm that it works on your end too

Should be fixed now ;) > Oh...that what you meant from "hopefully it would be solved by then" > > I thought you meant you fixed it, my mistake sorry xd > > Well, good news is no more `500` status code and if you need my logs of hyperpipe or piped, I would love to help! Should be fixed now ;) Could you just confirm that it works on your end too
Poster

AAAAAAA it works, thanks <3

Now It's time for my website to be listed (I guess?) #6 and I will wait for the backend docker support

AAAAAAA it works, thanks <3 Now It's time for my website to be listed (I guess?) https://codeberg.org/Hyperpipe/Hyperpipe/pulls/6 and I will wait for the backend docker support
snematoda closed this issue 10 months ago
Owner

https://codeberg.org/Hyperpipe/hyperpipe-backend#docker

BTW, the hostname for the proxy is the sane as the one you used for piped

https://codeberg.org/Hyperpipe/hyperpipe-backend#docker BTW, the hostname for the proxy is the sane as the one you used for piped
Poster

takes big gasp why not combine both in big docker-compose? I think it's task for me! or wait, can I??

Another question do I need to expose backend over nginx or not (I did expose it at hyperpipeapi.esmailelbob.xyz) but want to make sure

*takes big gasp* why not combine both in big docker-compose? I think it's task for me! or wait, can I?? Another question do I need to expose backend over nginx or not (I did expose it at hyperpipeapi.esmailelbob.xyz) but want to make sure
Owner

takes big gasp why not combine both in big docker-compose?

Just wanted to make it easier for people who wanted to host only the back end :)

I think it's task for me! or wait, can I??

Sure! Please feel free to contribute

do I need to expose backend over nginx

I believe so

Thank you for hosting hyperpipe 🙇 . I will add your backend to the list too

> takes big gasp why not combine both in big docker-compose? Just wanted to make it easier for people who wanted to host only the back end :) > I think it's task for me! or wait, can I?? Sure! Please feel free to contribute > do I need to expose backend over nginx I believe so Thank you for hosting hyperpipe 🙇 . I will add your backend to the list too
Poster

Just wanted to make it easier for people who wanted to host only the back end :)

Fair point but I want to host both :( can you mix it or lead me to the way and I do it

Sure! Please feel free to contribute

I was not asking for permission (I know it sounds mean, sorry) I was asking if there a way to do it, I'm noob with docker, after looking into it I found 2 Dockerfile files and I said hmm how docker will know front from backend xD

I believe so

yup already done! used your name scheme of "hyperpipeapi" haha!

Thank you for hosting hyperpipe 🙇 . I will add your backend to the list too

Your welcome <3, and thanks

> Just wanted to make it easier for people who wanted to host only the back end :) Fair point but I want to host both :( can you mix it or lead me to the way and I do it > Sure! Please feel free to contribute I was not asking for permission (I know it sounds mean, sorry) I was asking if there a *way* to do it, I'm noob with docker, after looking into it I found 2 Dockerfile files and I said hmm how docker will know front from backend xD > I believe so yup already done! used your name scheme of "hyperpipeapi" haha! > Thank you for hosting hyperpipe 🙇 . I will add your backend to the list too Your welcome <3, and thanks
Owner

Fair point but I want to host both :( can you mix it or lead me to the way and I do it

Okay, will make a simple bash script along with a single docker-compose.yml

used your name scheme of "hyperpipeapi" haha!

XD and I got it from piped's pipedapi.kavin.rocks

> Fair point but I want to host both :( can you mix it or lead me to the way and I do it Okay, will make a simple bash script along with a single `docker-compose.yml` > used your name scheme of "hyperpipeapi" haha! XD and I got it from piped's `pipedapi.kavin.rocks`
Poster

Okay, will make a simple bash script along with a single docker-compose.yml

Thank you thank you <3

XD and I got it from piped's pipedapi.kavin.rocks

oh...this is awkward, I wanted to choose a subdomain for it and saw your domain and said ah makes since because it's api for hyperpipe (wanted to name it hyperproxy to be honest) xD

> Okay, will make a simple bash script along with a single docker-compose.yml Thank you thank you <3 > XD and I got it from piped's pipedapi.kavin.rocks oh...this is awkward, I wanted to choose a subdomain for it and saw your domain and said ah makes since because it's api for hyperpipe (wanted to name it hyperproxy to be honest) xD
Owner

You may have to rename/remove the existing container

https://codeberg.org/Hyperpipe/Docker

You may have to rename/remove the existing container https://codeberg.org/Hyperpipe/Docker
Poster

I see you have taken piped approach of setup xD, another questions thought, how would I update it? like there are no docker images and git clone is inside gen.sh so that means I will have to retype everything so hmm, see this PR Hyperpipe/Docker#1 and tell me what you think and feel free to edit as needed

I see you have taken piped approach of setup xD, another questions thought, how would I update it? like there are no docker images and git clone is inside gen.sh so that means I will have to retype everything so hmm, see this PR https://codeberg.org/Hyperpipe/Docker/pulls/1 and tell me what you think and feel free to edit as needed
Poster

did we forget #!/bin/sh ??

did we forget #!/bin/sh ??
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: Hyperpipe/Hyperpipe#2
Loading…
There is no content yet.