#2029 Pairing Pebble on Android 10

Open
opened 2 weeks ago by vanous · 12 comments
vanous commented 2 weeks ago

@TaaviE finally i managed to do this. Long story short: as long as Companion pairing was enabled i could only once connect my Pebble OG (didn’t manage to catch log of that). Once i disabled CP and ALSO disabled the BLE scanning, it seemingly worked on the first go, i tried a two times.

See attached log, i have copy/pasted few logs in there (i entered new lines in between, see datestamps, just in case some of the lines are duplicated. This is because i get no logs on the phone (logging is enabled) so i used AStudio)... so maybe go from the end as it is quite long.

@TaaviE finally i managed to do this. Long story short: as long as Companion pairing was enabled i could only once connect my Pebble OG (didn't manage to catch log of that). Once i disabled CP and ALSO disabled the BLE scanning, it seemingly worked on the first go, i tried a two times. See attached log, i have copy/pasted few logs in there (i entered new lines in between, see datestamps, just in case some of the lines are duplicated. This is because i get no logs on the phone (logging is enabled) so i used AStudio)... so maybe go from the end as it is quite long.
2.3 MiB
vanous commented 2 weeks ago
Poster

Also, attached two logs from pairing Bip, one with BLE scan and CP on, one off. In both cases, all worked very seemlessly. The Pebble is much more error prone it seems.

Also, attached two logs from pairing Bip, one with BLE scan and CP on, one off. In both cases, all worked very seemlessly. The Pebble is much more error prone it seems.
TaaviE commented 2 weeks ago

So the logs do not contain a failure? I can’t do anything based on that, sorry.

So the logs do not contain a failure? I can't do anything based on that, sorry.
vanous commented 2 weeks ago
Poster

Pebble OG
new BLE discovery → OFF
CDM → ON

Can discover but cannot pair.

Pebble OG new BLE discovery → OFF CDM → ON Can discover but cannot pair.
vanous commented 2 weeks ago
Poster

Pebble OG
new BLE discovery → ON
CDM → ON

Cannot discover (only BLE, but i cannot pair that with Pebble afaik).

Pebble OG new BLE discovery → ON CDM → ON Cannot discover (only BLE, but i cannot pair that with Pebble afaik).
TaaviE commented 2 weeks ago

Cannot discover (only BLE, but i cannot pair that with Pebble afaik).

Did you try?

> Cannot discover (only BLE, but i cannot pair that with Pebble afaik). Did you try?
TaaviE commented 2 weeks ago

It might just be a BluetoothDevice.DEVICE_TYPE_DUAL device in which case pairing should work.

It might just be a `BluetoothDevice.DEVICE_TYPE_DUAL` device in which case pairing _should_ work.
ashimokawa commented 2 weeks ago
Owner

Before I forgot, I had a device that was NOT the pebble and pairing stopped working when companion device pairing was on.

Before I forgot, I had a device that was NOT the pebble and pairing stopped working when companion device pairing was on.
vanous commented 2 weeks ago
Poster

Cannot discover (only BLE, but i cannot pair that with Pebble afaik).

Did you try?

yes, no luck. So as per matrix chat: CDM → no pairing with Pebble. No CDM → can pair.

> > Cannot discover (only BLE, but i cannot pair that with Pebble afaik). > > Did you try? yes, no luck. So as per matrix chat: CDM → no pairing with Pebble. No CDM → can pair.
vanous commented 2 weeks ago
Poster

patch6 CDM pairing no success log

patch6 CDM pairing no success log
512 KiB
vanous commented 2 weeks ago
Poster

here is complete unflitered log

here is complete unflitered log
vanous added the
bug
label 1 week ago
vanous added the
device pebble
label 1 week ago
ashimokawa commented 1 week ago
Owner

@vanous

I tried so many times and ulitmately it worked (Amazfit Bip S), also nothing in the logs, just no companion pairing popup.

But success in the end, no idea.

@vanous I tried so many times and ulitmately it worked (Amazfit Bip S), also nothing in the logs, just no companion pairing popup. But success in the end, no idea.
vanous commented 1 week ago
Poster

@ashimokawa Bip also always works for me, zero issues. But no luck with Pebble OG.

@ashimokawa Bip also always works for me, zero issues. But no luck with Pebble OG.
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.