#2008 'Find device' function no longer works

Open
opened 3 weeks ago by Salt505 · 6 comments
Salt505 commented 3 weeks ago
name about
Bug report Find device function no longer works correctly

Before reporting a bug, please confirm the following:

I got Gadgetbridge from:

Your issue is:

Log attached to post

Steps to reproduce problem:

  1. On Amazfit Bip Lite go to ‘Settings’ and tap on ‘Find device’
  2. Gadgetbridge notification pops up, only one notification ding
  3. Gadgetbridge ‘Find my phone’ notification stays, can’t be swiped away
  4. Device never rings

Expected behavior:

  1. On Amazfit Bip Lite go to ‘Settings’ and tap on ‘Find device’
  2. Gadgetbridge ‘Find my phone’ window pops up, phone rings like a phone call until dismissed.

Your wearable device is:

Amazfit Bip Lite
Firmware version: v1.1.6.58

Your android version is:

Android 10

Your Gadgetbridge version is:

0.47.0

--- name: Bug report about: Find device function no longer works correctly --- #### Before reporting a bug, please confirm the following: - [X] I have read the [wiki](https://codeberg.org/Freeyourgadget/Gadgetbridge/wiki), and I didn't find a solution to my problem / an answer to my question. - [X] I have searched the [issues](https://codeberg.org/Freeyourgadget/Gadgetbridge/issues), and I didn't find a solution to my problem / an answer to my question. - [X] If you upload an image or other content, please make sure you have read and understood the [Codeberg Terms of Use](https://codeberg.org/codeberg/org/src/branch/master/TermsOfUse.md) ### I got Gadgetbridge from: * [X] F-Droid #### Your issue is: *Log attached to post* Steps to reproduce problem: 1. On Amazfit Bip Lite go to 'Settings' and tap on 'Find device' 2. Gadgetbridge notification pops up, only one notification ding 3. Gadgetbridge 'Find my phone' notification stays, can't be swiped away 4. Device never rings Expected behavior: 1. On Amazfit Bip Lite go to 'Settings' and tap on 'Find device' 2. Gadgetbridge 'Find my phone' window pops up, phone rings like a phone call until dismissed. #### Your wearable device is: Amazfit Bip Lite Firmware version: v1.1.6.58 #### Your android version is: Android 10 #### Your Gadgetbridge version is: 0.47.0
ashimokawa commented 3 weeks ago
Owner

@Salt505

Yes, confirmed.

There was PR #1814 which was supposed to fix it. I could not test, because I was at Android 9 at that time. I believe the fix was correct though.

It could be that the recent API bump by @TaaviE with #1927 broke it. But I am only guessing.

@Salt505 Yes, confirmed. There was PR #1814 which was supposed to fix it. I could not test, because I was at Android 9 at that time. I believe the fix was correct though. It could be that the recent API bump by @TaaviE with #1927 broke it. But I am only guessing.
ashimokawa added the
bug
label 3 weeks ago
TaaviE commented 3 weeks ago

They did try out and got Gadgetbridge excempt from battery optimizations using CompanionDeviceManager, meaning that it should have the ability to start the activity but it had no effect. It might be that it’s just broken on Android 10.

They did try out and got Gadgetbridge excempt from battery optimizations using CompanionDeviceManager, meaning that it should have the ability to start the activity but it had no effect. It might be that it's just broken on Android 10.
vanous commented 1 week ago
Collaborator

Confirmed here on Android 10. Seems like a result of the recent API level bump. Any way to fix this @TaaviE ?

Confirmed here on Android 10. Seems like a result of the [recent API level bump](https://codeberg.org/Freeyourgadget/Gadgetbridge/commit/b76a8267b8bc69fd1634256cbd704f52bbc495fe). Any way to fix this @TaaviE ?
ashimokawa commented 1 week ago
Owner

Yes I am pretty sure it worked on Android 10 before the API bump.
Unfortunatey we cannot go back since Android does not allow that.

Yes I am pretty sure it worked on Android 10 before the API bump. Unfortunatey we cannot go back since Android does not allow that.
TaaviE commented 1 week ago

Any way to fix this?

@vanous Yes, post logs.

> Any way to fix this? @vanous Yes, post logs.
vanous commented 1 week ago
Collaborator

I have been swamped at dayjob, so this is not easy right now. Will try as time permits.

I have been swamped at dayjob, so this is not easy right now. Will try as time permits.
Sign in to join this conversation.
No Milestone
No Assignees
4 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.