#1907 Gadgetbridge can't connect Amazfit GTS after Firmware Update.

Closed
opened 3 months ago by joebusch67 · 32 comments
name about
Bug report Create a report to help us improve

Before reporting a bug, please confirm the following:

I got Gadgetbridge from:

If you got it from Google Play, please note that version is unofficial and not supported here; it’s also often quite outdated. Please switch to one of the above versions if you can.

Your issue is:

If possible, please attach logs! that might help identifying the problem.

Gadgetbridge cant’t connect the Amazfit GTS.
The Amazfit says that i should update my Phone App.
This happens after a firmware update.
I checked the “Authkey” as described in the WIKI, but it doesent’t change.

Your wearable device is:

Please specify model and firmware version if possible
Amazfit GTS, Firmware Version v0.0.9.12

Your android version is:

Android 10

Your Gadgetbridge version is:

0.44.2

New issues about already solved/documented topics could be closed without further comments. Same for too generic or incomplete reports.

--- name: Bug report about: Create a report to help us improve --- #### Before reporting a bug, please confirm the following: - [x] I have read the [wiki](https://github.com/Freeyourgadget/Gadgetbridge/wiki), and I didn't find a solution to my problem / an answer to my question. - [x] I have searched the [issues](https://github.com/Freeyourgadget/Gadgetbridge/issues), and I didn't find a solution to my problem / an answer to my question. - [x] If you upload an image or other content, please make sure you have read and understood the [github policies and terms of services](https://help.github.com/articles/github-terms-of-service/#1-responsibility-for-user-generated-content) ### I got Gadgetbridge from: * [x] F-Droid * [ ] I built it myself from source code (specify tag / commit) If you got it from Google Play, please note [that version](https://github.com/TaaviE/Gadgetbridge) is unofficial and not supported here; it's also often quite outdated. Please switch to one of the above versions if you can. #### Your issue is: *If possible, please attach [logs](https://github.com/Freeyourgadget/Gadgetbridge/wiki/Log-Files)! that might help identifying the problem.* Gadgetbridge cant't connect the Amazfit GTS. The Amazfit says that i should update my Phone App. This happens after a firmware update. I checked the "Authkey" as described in the WIKI, but it doesent't change. #### Your wearable device is: *Please specify model and firmware version if possible* Amazfit GTS, Firmware Version v0.0.9.12 #### Your android version is: Android 10 #### Your Gadgetbridge version is: 0.44.2 *New issues about already solved/documented topics could be closed without further comments. Same for too generic or incomplete reports.*
joebusch67 closed this issue 3 months ago
ashimokawa commented 3 months ago
Owner

@joebusch67

If you updated with Gadgetbridge, did you also flash the resources? Normally when the watch says “Connect App” then it means that there is a mismatch between FW and RES.

Is the problem solved? I am asking because you closed the issue..

@joebusch67 If you updated with Gadgetbridge, did you also flash the resources? Normally when the watch says "Connect App" then it means that there is a mismatch between FW and RES. Is the problem solved? I am asking because you closed the issue..
joebusch67 reopened this issue 3 months ago
joebusch67 commented 3 months ago
Poster

Sorry, i did two mistakes. No the problem is not solved.
I did not know that i can update the watch with gadgetbridge. I made a update with the amazfit app.

Sorry, i did two mistakes. No the problem is not solved. I did not know that i can update the watch with gadgetbridge. I made a update with the amazfit app.
ashimokawa commented 3 months ago
Owner

@joebusch67

After flashing the firmware, did you unregister the watch with the Amazfit App? If so the pairing key is no longer valid.

You cannot connect Gadgetbridge at all or does it connect but only shows the update screen?

If so another reason besides res/fw mismatch might be that you chose a language in Gadgetbridge that is not supported by the firmware.

@joebusch67 After flashing the firmware, did you unregister the watch with the Amazfit App? If so the pairing key is no longer valid. You cannot connect Gadgetbridge at all or does it connect but only shows the update screen? If so another reason besides res/fw mismatch might be that you chose a language in Gadgetbridge that is not supported by the firmware.
joebusch67 commented 3 months ago
Poster

I don’t think thati unregister the watch, is it possible to check this?
And no, gadgetbridge can’t connect the watch at all.
I did not choose a language in the settings.

I don't think thati unregister the watch, is it possible to check this? And no, gadgetbridge can't connect the watch at all. I did not choose a language in the settings.
ashimokawa commented 3 months ago
Owner

Hmm the “connect app” screen also appears when factory resetting. When did it first appear?

Hmm the "connect app" screen also appears when factory resetting. When did it first appear?
joebusch67 commented 3 months ago
Poster

When gadgetbridge trys to add the watch, then the watch says after a few seconds that i have to update the app on the phone. I didn`t made a factory reset so far , should i do that? And start at all of the beginning?

When gadgetbridge trys to add the watch, then the watch says after a few seconds that i have to update the app on the phone. I didn`t made a factory reset so far , should i do that? And start at all of the beginning?
ashimokawa commented 3 months ago
Owner

@joebusch67

If you added the watch in Gadgetbridge before, there is not need to add it again.

It is weird, because, when it started to show the screen after connecting from Gadgetbridge it is an indicator that it is indeed a language problem (eg if your phone is in German it tries to set the watch to german but if the firmware is only chinese/english it might show that screen, expecting you to change to a firmware supporting german). So maybe you should set it to english (when adding the device long press, when it is added the gear icon).

But you had it running in Gadgetbridge with an old firmware, right?

@joebusch67 If you added the watch in Gadgetbridge before, there is not need to add it again. It is weird, because, when it started to show the screen after connecting from Gadgetbridge it is an indicator that it is indeed a language problem (eg if your phone is in German it tries to set the watch to german but if the firmware is only chinese/english it might show that screen, expecting you to change to a firmware supporting german). So maybe you should set it to english (when adding the device long press, when it is added the gear icon). But you had it running in Gadgetbridge with an old firmware, right?
sre commented 3 months ago

Same for me:

  1. start Amazfit, GTS FW got upgradet to latest 0.0.9.12 (incl. resources)
  2. force stop Amazfit app
  3. start gadgetbridge and connect to watch
  4. connection fails, GTS displays localized message

Connection failed. Update your app to the newest version to synchronize data.

My guess is, that the connection protocol changed.

Same for me: 1. start Amazfit, GTS FW got upgradet to latest 0.0.9.12 (incl. resources) 2. force stop Amazfit app 3. start gadgetbridge and connect to watch 4. connection fails, GTS displays localized message > Connection failed. Update your app to the newest version to synchronize data. My guess is, that the connection protocol changed.
joebusch67 commented 3 months ago
Poster

But you had it running in Gadgetbridge with an old firmware, right?

Yes i made a firmware update over the amazfit app, and afterwards i uninstall the amazfit app, and then gadgetbridge can’t conecct to the watch.

i also guess it’s a communication problem, as “sre” mentioned.

> But you had it running in Gadgetbridge with an old firmware, right? Yes i made a firmware update over the amazfit app, and afterwards i uninstall the amazfit app, and then gadgetbridge can't conecct to the watch. i also guess it's a communication problem, as "sre" mentioned.
neoyoyo commented 3 months ago

Hello,
Same here with my device “Amazfit GTR Lite” (dizygotic twin from the GTS).
Before the firmware upgrade, all the functions was working fine with Gadgetbridge v0.44.2

Here is my update process :

  1. Kill Gadgetbridge ;
  2. Defreeze Amazfit with Titanium backup ;
  3. Update Amazfit from Google Plasy store ;
  4. Launch Amazfit, the update begin automaticaly (first RES, then FW, then reboot) ;
  5. Check with Amazfit, everything is working fine ;
  6. Kill Amazfit ;
  7. Freeze Amazfit with Titanium Backup ;
  8. Launch Gadgetbridge : on the watch, screen display “update official app on your phone” ;
  9. Check the AUTHKEY : identical ;
  10. Reboot the watch then the phone : always the same message.

I’ve try to delete my watch from Gadgetbridge and add it again (specifying the AUTHKEY) : the message appears on the watch and on the phone the process didn’t finish.

It seems that Xiaomi/Huami has change something...

Notes :

  • The message on the watch appear when I try to pairing the wtach in my phone bluetooth’s settings.
  • The new firmware on my watch is v1.0.0.33
  • My phone (OnePlus 3) run LineageOS v16.0 (16.0-20200211 ; Android 9)
Hello, Same here with my device "Amazfit GTR Lite" (dizygotic twin from the GTS). Before the firmware upgrade, all the functions was working fine with Gadgetbridge v0.44.2 Here is my update process : 1. Kill Gadgetbridge ; 2. Defreeze Amazfit with Titanium backup ; 3. Update Amazfit from Google Plasy store ; 4. Launch Amazfit, the update begin automaticaly (first RES, then FW, then reboot) ; 5. Check with Amazfit, everything is working fine ; 6. Kill Amazfit ; 7. Freeze Amazfit with Titanium Backup ; 8. Launch Gadgetbridge : on the watch, screen display "update official app on your phone" ; 9. Check the AUTHKEY : identical ; 10. Reboot the watch then the phone : always the same message. I've try to delete my watch from Gadgetbridge and add it again (specifying the AUTHKEY) : the message appears on the watch and on the phone the process didn't finish. It seems that Xiaomi/Huami has change something... Notes : * The message on the watch appear when I try to pairing the wtach in my phone bluetooth's settings. * The new firmware on my watch is v1.0.0.33 * My phone (OnePlus 3) run LineageOS v16.0 (16.0-20200211 ; Android 9)
ashimokawa commented 3 months ago
Owner

You could send me a bluetooth hcidump when connecting with amazfit and tell me your authkey (privately via matrix).

I do not have the watch but I plan to buy one. Probably other devices will follow and have the same problem I guess :/

You could send me a bluetooth hcidump when connecting with amazfit and tell me your authkey (privately via matrix). I do not have the watch but I plan to buy one. Probably other devices will follow and have the same problem I guess :/
eQuark2 commented 3 months ago

Basically confirming messages above. Amazfit app updated my GTS firmware to version 0.0.9.11 and now Gadgetbridge can no longer connect.

I have made a btsnoop_hci.log of the Amazfit app connecting to the watch. I have looked through the file and it is too much for me to parse the whole thing. Is it safe to post it here publically or is there a better way?

Basically confirming messages above. Amazfit app updated my GTS firmware to version 0.0.9.11 and now Gadgetbridge can no longer connect. I have made a btsnoop_hci.log of the Amazfit app connecting to the watch. I have looked through the file and it is too much for me to parse the whole thing. Is it safe to post it here publically or is there a better way?
neoyoyo commented 3 months ago

@ashimokawa, I’ve done the btsnoop_hci.log and initiated a matrix thread, ready to share my authkey and the btsnoop_hci.log

@ashimokawa, I've done the btsnoop_hci.log and initiated a matrix thread, ready to share my authkey and the btsnoop_hci.log
ashimokawa commented 3 months ago
Owner

@neoyoyo

Thanks, lets continue on matrix then

@neoyoyo Thanks, lets continue on matrix then
sre commented 3 months ago

I noticed Gadgetbridge got connected to my GTS (with new FW) today when I accidently started Amazfit while gadgetbridge was trying to connect. I could reproduce this, so here is a workaround to extract data from the GTS while the problem is fixed in Gadgetbridge:

  1. Start Gadgetbridge, try to connect (ignore error message on the GTS)
  2. Start Amazfit
  3. Gadgetbridge succeeds to connect
  4. There is a fight with Amazfit and Gadgetbridge trying to connect to the watch, so kill Amazfit via Settings -> Apps -> Amazfit -> Force quit
  5. Gadgetbridge is still connected
I noticed Gadgetbridge got connected to my GTS (with new FW) today when I accidently started Amazfit while gadgetbridge was trying to connect. I could reproduce this, so here is a workaround to extract data from the GTS while the problem is fixed in Gadgetbridge: 1. Start Gadgetbridge, try to connect (ignore error message on the GTS) 2. Start Amazfit 3. Gadgetbridge succeeds to connect 4. There is a fight with Amazfit and Gadgetbridge trying to connect to the watch, so kill Amazfit via Settings -> Apps -> Amazfit -> Force quit 5. Gadgetbridge is still connected

There’s no way to downgrade firmware on this watch?

There's no way to downgrade firmware on this watch?
ashimokawa commented 3 months ago
Owner

@sre

Interesting, that might help with downgrading using Gadgetbridge afterwards.

I need testers which can compile Gadgetbridge themselves.
There is a branch called huami-auth-experiments, please try it if you can.

I do not have a GTS/GTR yet and Bip S is still “intact”

@sre Interesting, that might help with downgrading using Gadgetbridge afterwards. I need testers which can compile Gadgetbridge themselves. There is a branch called ```huami-auth-experiments```, please try it if you can. I do not have a GTS/GTR yet and Bip S is still "intact"
sre commented 3 months ago

@ashimokawa huami-auth-experiments fixes the connection issue for my GTS with FW 0.0.9.12.

@ashimokawa `huami-auth-experiments` fixes the connection issue for my GTS with FW 0.0.9.12.
OniBoni commented 3 months ago

@ashimokawa i can confirm that as well :)

@ashimokawa i can confirm that as well :)
ashimokawa commented 3 months ago
Owner

Cool, fix is in master now, will be in the next release. Closing this.

Cool, fix is in master now, will be in the next release. Closing this.
ashimokawa closed this issue 3 months ago
joebusch67 commented 3 months ago
Poster

Hi is the bug fix for this issue in version 0.45.0 of gadgetbridge resolved? i made a update to this version and the behavior is the same as before. i use the workarund starting amazfit, starting gadgetbridge, kill amazfit, and then gadgetbridge connects to the watch. But the amazfit app service makes a autostart. the notification tells me that both apps are connected.

Hi is the bug fix for this issue in version 0.45.0 of gadgetbridge resolved? i made a update to this version and the behavior is the same as before. i use the workarund starting amazfit, starting gadgetbridge, kill amazfit, and then gadgetbridge connects to the watch. But the amazfit app service makes a autostart. the notification tells me that both apps are connected.

@joebusch67 I think the fix is in 0.45.1. and that version isn’t available on F-Droid yet. Maybe you can compile it yourself, I don’t know how to do that though. Would like to.

@joebusch67 I think the fix is in 0.45.1. and that version isn't available on F-Droid yet. Maybe you can compile it yourself, I don't know how to do that though. Would like to.
ashimokawa commented 3 months ago
Owner

Yes, fixed in 0.45.1, when F-Droid finally published 0.45.0, we had already 0.45.1 ready. There is a completely irreguar delay :/

Self compiling is not that hard:

  • download and install the android sdk (no need for android studio)
  • point ANDROID_HOME environment variable to the sdk
  • execute ./gradlew assembleDebug in the checkout out Gadgebridge source tree
  • adb install the resulting apk

The problem is that you will loose your data.

Yes, fixed in 0.45.1, when F-Droid finally published 0.45.0, we had already 0.45.1 ready. There is a completely irreguar delay :/ Self compiling is not that hard: * download and install the android sdk (no need for android studio) * point ANDROID_HOME environment variable to the sdk * execute ./gradlew assembleDebug in the checkout out Gadgebridge source tree * adb install the resulting apk The problem is that you will loose your data.
joebusch67 commented 3 months ago
Poster

hi, thanks for your answers, i will try it.

hi, thanks for your answers, i will try it.

When I execute gradlew assembleDebug I’m getting an error:

FAILURE: Build failed with an exception.
What went wrong:
Could not initialize class org.codehaus.groovy.runtime.InvokerHelper

Tried searching for solution, didn’t find anything. Anybody knows what’s up?

Sorry for bothering you with possible rookie stuff.

When I execute gradlew assembleDebug I'm getting an error: *FAILURE: Build failed with an exception. What went wrong: Could not initialize class org.codehaus.groovy.runtime.InvokerHelper* Tried searching for solution, didn't find anything. Anybody knows what's up? Sorry for bothering you with possible rookie stuff.
neoyoyo commented 3 months ago

Hi,
v0.45.1 is available on F-Droid and it rocks !

Hi, v0.45.1 is available on F-Droid and it rocks !
joebusch67 commented 3 months ago
Poster

great message and great work. thank you.

great message and great work. thank you.
ashimokawa commented 3 months ago
Owner

@neoyoyo

Is the activity data for you also broken on the GTR, so that you will see a huge step count?

If so I need to know since which firmware,

@neoyoyo Is the activity data for you also broken on the GTR, so that you will see a huge step count? If so I need to know since which firmware,
neoyoyo commented 3 months ago

@ashimokawa
Yes it’s the same as issue #1924, and as far as I know it appears since the last firmware how broke the connection (v1.0.0.33 on my GTR Lite), subject of this issue.
See screenshot attached (Gadgetbridge is in v0.45.1), I’m not that sporty so I don’t look at the activity panel that much 😅

@ashimokawa Yes it's the same as issue #1924, and as far as I know it appears since the last firmware how broke the connection (v1.0.0.33 on my GTR Lite), subject of this issue. See screenshot attached (Gadgetbridge is in v0.45.1), I'm not that sporty so I don't look at the activity panel that much 😅
ashimokawa commented 3 months ago
Owner

@neoyoyo

Can you name a firmware release where it still worked?
I can easily fix it but I would need to specify since when the format changed to not break older versions.

@neoyoyo Can you name a firmware release where it still worked? I can easily fix it but I would need to specify since when the format changed to not break older versions.
neoyoyo commented 3 months ago

@ashimokawa
I don’t have the version history, but after some research I found a forum who indicates some firmware history (https://4pda.ru/forum/index.php?showtopic=959584).
So for my watch, the first firmware where this issue appears is the v1.0.0.33 published the 06-24-2020.
At this time, here are new the firmware versions published for this series of Huami products :

  • GTR 47mm (model A1902, global version) : v1.3.5.79 ;
  • GTR 42mm (model A1910, global version) : v0.1.1.15 ;
  • GTR Lite (model A1922) : v1.0.0.33 ;
  • GTS : v0.0.9.11.

So I think that the issue is not present on firmware prior to this versions.

Note : for the chinese versions of GTR 47mm (model A1901) and GTR 42mm (model A1909) there’s is no informations, but have Chinese people the opportunity to use Gadgetbridge ?

@ashimokawa I don't have the version history, but after some research I found a forum who indicates some firmware history (https://4pda.ru/forum/index.php?showtopic=959584). So for my watch, the first firmware where this issue appears is the v1.0.0.33 published the 06-24-2020. At this time, here are new the firmware versions published for this series of Huami products : * GTR 47mm (model A1902, global version) : v1.3.5.79 ; * GTR 42mm (model A1910, global version) : v0.1.1.15 ; * GTR Lite (model A1922) : v1.0.0.33 ; * GTS : v0.0.9.11. So I think that the issue is not present on firmware prior to this versions. Note : for the chinese versions of GTR 47mm (model A1901) and GTR 42mm (model A1909) there's is no informations, but have Chinese people the opportunity to use Gadgetbridge ?
ashimokawa commented 3 months ago
Owner

@neoyoyo

Thanks I tried to fix this with the version information you provided 👍

Oh and I assume we have a lot of chinese users.

@neoyoyo Thanks I tried to fix this with the version information you provided 👍 Oh and I assume we have a lot of chinese users.
Sign in to join this conversation.
No Milestone
No Assignees
7 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.