#1819 Bip lite firnmware flashing is not supported

Closed
opened 2 months ago by UnFriendlyChemist · 2 comments

Greetings,

After reading #1681 and #1479 , I have noticed that the firmware flash is disabled for the amazfi bip lite. However, recently, in the BipOS forum, they mention that Bip firmware (non lite) is compatible with the bip lite, as long as the Mi Fit app is not used and some features are hidden from the watch (gps and compass). I think people are using other apps to flash the lite because it is disabled in gadgetbridge. Therefore I wonder if it would be possible to add flashing capability (if necessary, with a warning?) for the lite bip.

If not, then at least update the error message in line 77 of https://codeberg.org/Freeyourgadget/Gadgetbridge/src/branch/master/app/src/main/java/nodomain/freeyourgadget/gadgetbridge/devices/miband/AbstractMiBandFWInstallHandler.java could be updated so that people know that the flashing is dissabled for the bip lite.

Before reporting a bug, please confirm the following:

  • I have read the wiki, and I didn't find a solution to my problem / an answer to my question.
  • I have searched the issues, and I didn't find a solution to my problem / an answer to my question.
  • If you upload an image or other content, please make sure you have read and understood the github policies and terms of services

I got Gadgetbridge from:

  • F-Droid
  • I built it myself from source code (specify tag / commit)

Your wearable device is:

Amazfit bip lite

Your android version is:

7.1.1

Your Gadgetbridge version is:

Latest from F-droid at the moment, 0.42.1

New issues about already solved/documented topics could be closed without further comments. Same for too generic or incomplete reports.

Greetings, After reading #1681 and #1479 , I have noticed that the firmware flash is disabled for the amazfi bip lite. However, recently, in the BipOS forum, they mention that Bip firmware (non lite) is compatible with the bip lite, as long as the Mi Fit app is not used and some features are hidden from the watch (gps and compass). I think people are using other apps to flash the lite because it is disabled in gadgetbridge. Therefore I wonder if it would be possible to add flashing capability (if necessary, with a warning?) for the lite bip. If not, then at least update the error message in line 77 of https://codeberg.org/Freeyourgadget/Gadgetbridge/src/branch/master/app/src/main/java/nodomain/freeyourgadget/gadgetbridge/devices/miband/AbstractMiBandFWInstallHandler.java could be updated so that people know that the flashing is dissabled for the bip lite. #### Before reporting a bug, please confirm the following: - [x] I have read the [wiki](https://github.com/Freeyourgadget/Gadgetbridge/wiki), and I didn't find a solution to my problem / an answer to my question. - [x] I have searched the [issues](https://github.com/Freeyourgadget/Gadgetbridge/issues), and I didn't find a solution to my problem / an answer to my question. - [x] If you upload an image or other content, please make sure you have read and understood the [github policies and terms of services](https://help.github.com/articles/github-terms-of-service/#1-responsibility-for-user-generated-content) ### I got Gadgetbridge from: * [x] F-Droid * [ ] I built it myself from source code (specify tag / commit) #### Your wearable device is: Amazfit bip lite #### Your android version is: 7.1.1 #### Your Gadgetbridge version is: Latest from F-droid at the moment, 0.42.1 *New issues about already solved/documented topics could be closed without further comments. Same for too generic or incomplete reports.*
ashimokawa commented 2 months ago
Owner

@UnFriendlyChemist

Flashing is not disabled afaik, but flashing non-bip lite firmware is. It is a good idea to allow flashing the bip firmware for the brave ones :)

@UnFriendlyChemist Flashing is not disabled afaik, but flashing non-bip lite firmware is. It is a good idea to allow flashing the bip firmware for the brave ones :)
ashimokawa self-assigned this 2 months ago
ashimokawa commented 2 months ago
Owner

@UnFriendlyChemist

Implemented blindly (I do not have the device).

Don't know if you can test master. Else you would have to wait for 0.43.1

@UnFriendlyChemist Implemented blindly (I do not have the device). Don't know if you can test master. Else you would have to wait for 0.43.1
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.