Mi Band: Connectivity improvement? #156

Closed
by 6arms1leg opened 6 years ago · 6 comments
6arms1leg commented 6 years ago (Migrated from github.com)
Owner

After trying most of the firmwares for my Mi Band with the recent GB versions, I noticed some connectivity issues when I closed the app and tried to re-connect my Mi Band again afterwards. It often takes several tries with closing and re-opening GB until I can re-connect. I think (hard to measure) this issue has improved with FW 1.0.10.14, but it's still there.
Do you have the same problem?
Is there any chance, this can be improved or might it be an issue with my device's BT capabilities (Samsung Galaxy S3, Cyanogenmod 11 (stable)) or is it an issue with the Mi Band itself?
Thanks for your help!

After trying most of the firmwares for my Mi Band with the recent GB versions, I noticed some connectivity issues when I closed the app and tried to re-connect my Mi Band again afterwards. It often takes several tries with closing and re-opening GB until I can re-connect. I think (hard to measure) this issue has improved with FW 1.0.10.14, but it's still there. Do you have the same problem? Is there any chance, this can be improved or might it be an issue with my device's BT capabilities (Samsung Galaxy S3, Cyanogenmod 11 (stable)) or is it an issue with the Mi Band itself? Thanks for your help!
Owner

Thanks for opening this issue. We do experience the same thing and will find a fix for this.

A small improvement for you: you don't need to quit Gadgetbridge in order to make another connection attempt. You can simply long-press the device item and press "Disconnect" and connect again.

Thanks for opening this issue. We do experience the same thing and will find a fix for this. A small improvement for you: you don't need to quit Gadgetbridge in order to make another connection attempt. You can simply long-press the device item and press "Disconnect" and connect again.
Owner
For reference: - http://stackoverflow.com/questions/27017224/why-the-app-doesnt-reconnect-to-the-ble-device-when-set-autoconnect-to-true-in - http://stackoverflow.com/questions/24763204/android-ble-automatic-re-connect-after-spontaneous-disconnect
6arms1leg commented 6 years ago (Migrated from github.com)
Poster
Owner

Just a note: I have the impression that it is working better sometimes when you choose "connect new device" from the menu on the start screen during the connection process. I could be wrong though (again, it's hard to measure).

Just a note: I have the impression that it is working better sometimes when you choose "connect new device" from the menu on the start screen during the connection process. I could be wrong though (again, it's hard to measure).
jmferrer commented 6 years ago (Migrated from github.com)
Owner

MiBand has a FW 5.15.10.14 and I have connectivity issues so I cannot use notifications. Is there any FW version that works well with gadgetbridge?

MiBand has a FW 5.15.10.14 and I have connectivity issues so I cannot use notifications. Is there any FW version that works well with gadgetbridge?
Owner

See https://github.com/Freeyourgadget/Gadgetbridge/wiki/Mi-Band-Firmware-information

You can upgrade and downgrade firmware with Gadgetbridge, but we do not provide these files.

See https://github.com/Freeyourgadget/Gadgetbridge/wiki/Mi-Band-Firmware-information You can upgrade and downgrade firmware with Gadgetbridge, but we do not provide these files.
Owner

This should be fixed by now. See #249 for details.

This should be fixed by now. See #249 for details.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.