Mi Band 3: frequency of the heart rate measurements #1356

Closed
by matttbe opened 3 years ago · 7 comments
matttbe commented 3 years ago (Migrated from github.com)
Owner

Hello,

Thank you for developing and maintaining GadgetBridge!

I am currently using the version from Git.

In the settings, I set the parameter "Whole day HR measurements" to 30 minutes (also tried with 1 hour) but it seems that the measurements are taken more frequently than that. Sometimes it looks like it is taken each minutes.

Note that I am not using the "Use heart rate sensor to improve sleep detection".

Did anybody else notice that? Maybe they don't use the same time unit with the Mi Band 3 than before.

Thank you for your support.

Matt

Hello, Thank you for developing and maintaining GadgetBridge! I am currently using the version from Git. In the settings, I set the parameter "Whole day HR measurements" to 30 minutes (also tried with 1 hour) but it seems that the measurements are taken more frequently than that. Sometimes it looks like it is taken each minutes. Note that I am not using the "Use heart rate sensor to improve sleep detection". Did anybody else notice that? Maybe they don't use the same time unit with the Mi Band 3 than before. Thank you for your support. Matt
matttbe commented 3 years ago (Migrated from github.com)
Poster
Owner

When looking at the graphs, I can see that the frequency is quite high:

high frequency

Except if the frequency of high only when moving?

When looking at the graphs, I can see that the frequency is quite high: ![high frequency](https://i.imgur.com/dM0tWIY.png) Except if the frequency of high only when moving?
Elwood21 commented 3 years ago (Migrated from github.com)
Owner

Same issue on the bip. It measures heart rate every 2/3 inutes even if I set an hour delay between each measurement.

Same issue on the bip. It measures heart rate every 2/3 inutes even if I set an hour delay between each measurement.
xandro0777 commented 3 years ago (Migrated from github.com)
Owner

Do you have the option HR for sleep recognition turned on? This might cause HR measurements every 2-3 minutes.

Do you have the option HR for sleep recognition turned on? This might cause HR measurements every 2-3 minutes.
matttbe commented 3 years ago (Migrated from github.com)
Poster
Owner

Do you have the option HR for sleep recognition turned on?

I am not using this option: "Use heart rate sensor to improve sleep detection".

> Do you have the option HR for sleep recognition turned on? I am not using this option: "Use heart rate sensor to improve sleep detection".
gch1p commented 3 years ago (Migrated from github.com)
Owner

I have the same problem with Mi Band 3.

I have the same problem with Mi Band 3.
N46AN commented 3 years ago (Migrated from github.com)
Owner

Verified with Mi Band 3 HW 0.18.3.4, FW 2.3.0.2

Verified with Mi Band 3 HW 0.18.3.4, FW 2.3.0.2
Owner

For the record and explanation: the way this works is that you set up how often it should measure at minimum, but if you perform some activity, the band will measure more frequently, to catch the activity. This is a feature of the band, not of Gadgetbridge. So basically, i set it to 1h, and am sure that i will have all my activities measured, but only small battery drainage if i do not move. Part of the issue is that even small movement can trigger the measurement.

I will close this now.

For the record and explanation: the way this works is that you set up how often it should measure at minimum, but if you perform some activity, the band will measure more frequently, to catch the activity. This is a feature of the band, not of Gadgetbridge. So basically, i set it to 1h, and am sure that i will have all my activities measured, but only small battery drainage if i do not move. Part of the issue is that even small movement can trigger the measurement. I will close this now.
vanous closed this issue 12 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.