BIP: reconnection problem, and silent disconnect #1334

Closed
by Pepe404 opened 3 years ago · 9 comments
Pepe404 commented 3 years ago (Migrated from github.com)
Owner

Before reporting a bug, please confirm the following:

  • [ x] I have read the wiki, and I didn't find a solution to my problem / an answer to my question.
  • [ x] I have searched the issues, and I didn't find a solution to my problem / an answer to my question.
  • [x ] If you upload an image or other content, please make sure you have read and understood the github policies and terms of services

Your issue is:

Reconnection is still unreliable, and silent disconnect is still here. Sometimes the BT icon on the watch will show that it's not connected, sometimes not, everything looks normal, GB always displays "connected" state, but finally I find, that I don't get any new notifications for a long time. Disconnecting and connecting in GB "fixes" the problem (untill the next silent disconnect).
Problem usually appears after a day or two of usage, since a fresh Gadgetbridge installation.

Your wearable device is:

Amazfit BIP, latest FW (problem also exists with with previous FW and previous GB releases)

Your android version is:

8.1 (but same for 5.0)

Your Gadgetbridge version is:

0.31.1 (but same for all previous GB releases)

#### Before reporting a bug, please confirm the following: - [ x] I have read the [wiki](https://github.com/Freeyourgadget/Gadgetbridge/wiki), and I didn't find a solution to my problem / an answer to my question. - [ x] I have searched the [issues](https://github.com/Freeyourgadget/Gadgetbridge/issues), and I didn't find a solution to my problem / an answer to my question. - [x ] If you upload an image or other content, please make sure you have read and understood the [github policies and terms of services](https://help.github.com/articles/github-terms-of-service/#1-responsibility-for-user-generated-content) #### Your issue is: Reconnection is still unreliable, and silent disconnect is still here. Sometimes the BT icon on the watch will show that it's not connected, sometimes not, everything looks normal, GB always displays "connected" state, but finally I find, that I don't get any new notifications for a long time. Disconnecting and connecting in GB "fixes" the problem (untill the next silent disconnect). Problem usually appears after a day or two of usage, since a fresh Gadgetbridge installation. #### Your wearable device is: Amazfit BIP, latest FW (problem also exists with with previous FW and previous GB releases) #### Your android version is: 8.1 (but same for 5.0) #### Your Gadgetbridge version is: 0.31.1 (but same for all previous GB releases)
Pepe404 commented 3 years ago (Migrated from github.com)
Poster
Owner

Without a reliable connection/reconnection, this software is not worth much, and I don't see anything regarding this problem in recent Changelogs. Does it mean this serious problem will never be addressed?

Without a reliable connection/reconnection, this software is not worth much, and I don't see anything regarding this problem in recent Changelogs. Does it mean this serious problem will never be addressed?
KeironO commented 3 years ago (Migrated from github.com)
Owner

I think it's time to start surveying people about these dis/reconnection issues that seem to be prevalent.

What mobile device are you using to sync your Amazfit BIP?

I think it's time to start surveying people about these dis/reconnection issues that seem to be prevalent. What mobile device are you using to sync your Amazfit BIP?
MMurzik commented 3 years ago (Migrated from github.com)
Owner

I catched this issue when my Amazfit Bip was paired with Gadgetbridge, but was unpaired with Android bluetooth settings. Try to pair your Amazfit Bip both with Android bluetooth settings and Gadgetbridge. This resolves this issue for me.

I catched this issue when my Amazfit Bip was paired with Gadgetbridge, but was unpaired with Android bluetooth settings. Try to pair your Amazfit Bip **both** with Android bluetooth settings and Gadgetbridge. This resolves this issue for me.
Collaborator

Auto-reconnection has been implemented and works well, can this issue be closed now? Thank you.

Auto-reconnection has been implemented and works well, can this issue be closed now? Thank you.

No, the problem still persists in 0.41.1 (installed from F-Droid). Android 9, Moto G7 Power, Amazfit Bip fw 1.1.6.36, hw 0.11.19.5. Usually disconnects when I go out of range and then sits indefinitely long in "Connecting" state. Long tap to disconnect and then short tap to connect makes the app connect. The bluetooth icon on the watch indicates there is a connection and in BT settings the device is also visible.

No, the problem still persists in 0.41.1 (installed from F-Droid). Android 9, Moto G7 Power, Amazfit Bip fw 1.1.6.36, hw 0.11.19.5. Usually disconnects when I go out of range and then sits indefinitely long in "Connecting" state. Long tap to disconnect and then short tap to connect makes the app connect. The bluetooth icon on the watch indicates there is a connection and in BT settings the device is also visible.
Owner

@rkfg
Logs please ;)

@rkfg Logs please ;)

I tried to reproduce it artificially at home and it reconnected fine. At work it gets stuck when I go to another room for a while and then back. I'll try it this Monday then but from what I remember there was just nothing in the log after GB said it tries to reconnect.

I tried to reproduce it artificially at home and it reconnected fine. At work it gets stuck when I go to another room for a while and then back. I'll try it this Monday then but from what I remember there was just nothing in the log after GB said it tries to reconnect.

Ok, GB is stuck on "Fetching activity data" after I went away and returned back after ~5 minutes. Bip showed no BT connection and when I pressed the button on the watch it apparently got connected but GB didn't. There's a lot of spam about "Ignore notification" so it's a bit hard to find the relevant part of the log.

I see there's an NPE that's probably caused this but in my original issue it was stuck on "Connecting" (and there was nothing interesting in the log) so it might be something different. I'll keep watching it.

Ok, GB is stuck on "Fetching activity data" after I went away and returned back after ~5 minutes. Bip showed no BT connection and when I pressed the button on the watch it apparently got connected but GB didn't. There's a lot of spam about "Ignore notification" so it's a bit hard to find the relevant part of the log. I see there's an NPE that's probably caused this but in my original issue it was stuck on "Connecting" (and there was nothing interesting in the log) so it might be something different. I'll keep watching it.

For the record, after updating to 0.42.0 I don't have this issue anymore. I often lose connection at work due to going out of range and when I'm back it reconnects quickly.

For the record, after updating to 0.42.0 I don't have this issue anymore. I often lose connection at work due to going out of range and when I'm back it reconnects quickly.
vanous closed this issue 11 months ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.