Not wearing Mi Band 3 is sometimes detected as being asleep #1279

Closed
by jannblm opened 3 years ago · 2 comments
jannblm commented 3 years ago (Migrated from github.com)
Owner

Before reporting a bug, please confirm the following:

  • I have read the wiki, and I didn't find a solution to my problem / an answer to my question.
  • I have searched the issues, and I didn't find a solution to my problem / an answer to my question.
  • If you upload an image or other content, please make sure you have read and understood the github policies and terms of services

Your issue is:

Sometimes, I take off my Mi Band 3 in the morning and leave it on a table. If I do that there's a chance that it'll think I'm asleep until I wear it again for a while, making my sleep stats sometimes display that I've slept 20 hours.

Screenshot 1 Screenshot 2

Your wearable device is:

Mi Band 3 - FW: 1.5.0.2 (although this has happened with earlier versions)

Your android version is:

7.1.2 Nougat

Your Gadgetbridge version is:

30.0 (although the issue has been present since the first version that supported Mi Band 3)

#### Before reporting a bug, please confirm the following: - [x] I have read the [wiki](https://github.com/Freeyourgadget/Gadgetbridge/wiki), and I didn't find a solution to my problem / an answer to my question. - [x] I have searched the [issues](https://github.com/Freeyourgadget/Gadgetbridge/issues), and I didn't find a solution to my problem / an answer to my question. - [x] If you upload an image or other content, please make sure you have read and understood the [github policies and terms of services](https://help.github.com/articles/github-terms-of-service/#1-responsibility-for-user-generated-content) #### Your issue is: Sometimes, I take off my Mi Band 3 in the morning and leave it on a table. If I do that there's a chance that it'll think I'm asleep until I wear it again for a while, making my sleep stats sometimes display that I've slept 20 hours. ![Screenshot 1](https://user-images.githubusercontent.com/26850660/45927759-773e4700-bf27-11e8-9a8a-673dabb77108.png) ![Screenshot 2](https://user-images.githubusercontent.com/26850660/45927761-7c9b9180-bf27-11e8-862c-a7e679f5e63f.png) #### Your wearable device is: Mi Band 3 - FW: 1.5.0.2 (although this has happened with earlier versions) #### Your android version is: 7.1.2 Nougat #### Your Gadgetbridge version is: 30.0 (although the issue has been present since the first version that supported Mi Band 3)
Owner

Thanks for the report, we seem to be in need of some postprocessing of the recognized "activty" here.

Thanks for the report, we seem to be in need of some postprocessing of the recognized "activty" here.
Owner

This is a duplicate of #1277 which I believe has been solved by the Sleep zones, long time ago in 371ac276a5

This is a duplicate of https://codeberg.org/Freeyourgadget/Gadgetbridge/issues/1277 which I believe has been solved by the Sleep zones, long time ago in 371ac276a5
vanous closed this issue 11 months ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.