Notifications sometimes lost on Pebble Time Steel and Android 8 and 8.1 #1149

Open
by Alinaki opened 3 years ago · 2 comments
Alinaki commented 3 years ago (Migrated from github.com)
Owner

Before opening an issue please confirm the following:

  • I have read the wiki, and I didn't find a solution to my problem / an answer to my question.
  • I have searched the issues, and I didn't find a solution to my problem / an answer to my question.
  • If you upload an image or other content, please make sure you have read and understood the github policies and terms of services

Your issue is:

Sometimes notifications are just lost. My Pebble is still connected to the Gadgetbridge (I use Mario Time watchface that vibrates on connection lost), but neither app notifications nor debug notifications aren't appear on Pebble. Even incoming calls aren't display on the Pebble screen. Only reconnection helps. For example, I've got Telegram message at 05:59:22.376 but after that I didn't get any on the Pebble.

I can't find any pattern in the notifications lost yet. They all seems similar for me in the logs attached.
gadgetbridge.log

Your wearable device is:

Pebble Time Steel v4.3

Your android version is:

8.1.0 (EMUI 8.1.0) Honor 10
8.0.0 (EMUI 8.0.0) Huawei P20 Lite

Your Gadgetbridge version is:

0.27.0

#### Before opening an issue please confirm the following: - [x] I have read the [wiki](https://github.com/Freeyourgadget/Gadgetbridge/wiki), and I didn't find a solution to my problem / an answer to my question. - [x] I have searched the [issues](https://github.com/Freeyourgadget/Gadgetbridge/issues), and I didn't find a solution to my problem / an answer to my question. - [x] If you upload an image or other content, please make sure you have read and understood the [github policies and terms of services](https://help.github.com/articles/github-terms-of-service/#1-responsibility-for-user-generated-content) #### Your issue is: Sometimes notifications are just lost. My Pebble is still connected to the Gadgetbridge (I use Mario Time watchface that vibrates on connection lost), but neither app notifications nor debug notifications aren't appear on Pebble. Even incoming calls aren't display on the Pebble screen. Only reconnection helps. For example, I've got Telegram message at 05:59:22.376 but after that I didn't get any on the Pebble. I can't find any pattern in the notifications lost yet. They all seems similar for me in the logs attached. [gadgetbridge.log](https://github.com/Freeyourgadget/Gadgetbridge/files/2180027/gadgetbridge.log) #### Your wearable device is: Pebble Time Steel v4.3 #### Your android version is: 8.1.0 (EMUI 8.1.0) Honor 10 8.0.0 (EMUI 8.0.0) Huawei P20 Lite #### Your Gadgetbridge version is: 0.27.0
karlyeurl commented 3 years ago (Migrated from github.com)
Owner

@Alinaki Have you solved your issue? I have a similar problem with my Pebble Steel, but I'm not sure it's a gadgetbridge-related issue. I think it's a case of EMUI being too agressive on battery optimization.

@Alinaki Have you solved your issue? I have a similar problem with my Pebble Steel, but I'm not sure it's a gadgetbridge-related issue. I think it's a case of EMUI being too agressive on battery optimization.
Alinaki commented 3 years ago (Migrated from github.com)
Poster
Owner

@Alinaki Have you solved your issue? I have a similar problem with my Pebble Steel, but I'm not sure it's a gadgetbridge-related issue. I think it's a case of EMUI being too agressive on battery optimization.

I turned off battery optimization at the "Special Access" in the "Applications", but I didn't fully tested it yet. But it helps with WearOS gadgets.

> @Alinaki Have you solved your issue? I have a similar problem with my Pebble Steel, but I'm not sure it's a gadgetbridge-related issue. I think it's a case of EMUI being too agressive on battery optimization. I turned off battery optimization at the "Special Access" in the "Applications", but I didn't fully tested it yet. But it helps with WearOS gadgets.
vanous added the
notifications
label 1 year ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.