Feature: Merge all hosts lists into a single file #2

Closed
opened 3 months ago by gallegonovato · 7 comments

Good afternoon:

I currently use your https://codeberg.org/Cyanic76/Hosts/src/branch/pages/corporations and https://hosts.cyanic.tk/cyanicHosts.txt hosts.

And my request. Is if you would be so kind to put all the hosts of https://codeberg.org/Cyanic76/Hosts/src/branch/pages/corporations in one host.

So I can put them in Adaway, without having to go one by one. I know that maybe you will tell me that hp, mcafee for a mobile...

But I currently have a mobile with Lineageos without anything from google. And some modifications for privacy. And I am also a privacy maniac.

Best regards and thanks for your time

Good afternoon: I currently use your https://codeberg.org/Cyanic76/Hosts/src/branch/pages/corporations and https://hosts.cyanic.tk/cyanicHosts.txt hosts. And my request. Is if you would be so kind to put all the hosts of https://codeberg.org/Cyanic76/Hosts/src/branch/pages/corporations in one host. So I can put them in Adaway, without having to go one by one. I know that maybe you will tell me that hp, mcafee for a mobile... But I currently have a mobile with Lineageos without anything from google. And some modifications for privacy. And I am also a privacy maniac. Best regards and thanks for your time
Owner

Hi,

First of all, thanks for this issue.

Just so you know, I included a .sh script in the merge_all folder that you can run directly on Android or Linux. All you need is a terminal with git installed so you can clone the repo.

I'll see, however, if there's any way I could do such a thing with Woodpecker CI. Else, I'll publish a .txt file with all hosts I referenced.

Hi, First of all, thanks for this issue. Just so you know, I included a .sh script in the merge_all folder that you can run directly on Android or Linux. All you need is a terminal with git installed so you can clone the repo. I'll see, however, if there's any way I could do such a thing with Woodpecker CI. Else, I'll publish a .txt file with all hosts I referenced.
Cyanic76 added the
enhancement
label 3 months ago
Owner

Hi!

Thank you very much for suggesting that idea.

I finally got Woodpecker CI to do the job and keep a new file up-to-date - it merges all corporations/*.txt files and the main cyanicHosts.txt file in a new allhosts.txt file on every list update.

You wrote that you're an AdAway user, I am one as well. If you want to block all hosts I've referenced so far, use one of those URLs:

If the hosts.cyanic.tk URL doesn't work, I recommend using the codeberg.org raw link instead.

Have a nice day!

Hi! Thank you very much for suggesting that idea. I finally got Woodpecker CI to [do the job](https://ci.codeberg.org/Cyanic76/Hosts) and keep a new file up-to-date - it merges all `corporations/*.txt` files and the main `cyanicHosts.txt` file in a new `allhosts.txt` file on every list update. You wrote that you're an AdAway user, I am one as well. If you want to block **all** hosts I've referenced so far, use one of those URLs: - https://codeberg.org/Cyanic76/Hosts/raw/branch/pages/allhosts.txt - https://hosts.cyanic.tk/allhosts.txt If the hosts.cyanic.tk URL [doesn't work](https://codeberg.org/Cyanic76/Hosts/issues/1), I recommend using the codeberg.org raw link instead. Have a nice day!
Cyanic76 changed title from request for a favor to Feature: Merge all hosts lists into a single file 3 months ago
Cyanic76 added reference pages 3 months ago
Cyanic76 referenced this issue from a commit 3 months ago
Cyanic76 referenced this issue from a commit 3 months ago
Cyanic76 closed this issue 3 months ago

Good afternoon:
First of all let me apologize for responding so late. But my wife had to go to the hospital and it was impossible for me to answer you earlier.
I thank you from the bottom of my heart for all your work and effort. And for making my request come true.
I add afwall+ to adaway to block things I don't want to connect. But still the network and the web are plagued with trackers, advertising or connections to sites that should not have: Facebook, Amazon, Google, etc etc etc....
Now thanks to you you are more deprived of those connections.
A hug

Good afternoon: First of all let me apologize for responding so late. But my wife had to go to the hospital and it was impossible for me to answer you earlier. I thank you from the bottom of my heart for all your work and effort. And for making my request come true. I add afwall+ to adaway to block things I don't want to connect. But still the network and the web are plagued with trackers, advertising or connections to sites that should not have: Facebook, Amazon, Google, etc etc etc.... Now thanks to you you are more deprived of those connections. A hug
Owner

Hi!

I'm very sorry for what's happening right now to your wife and you. You don't need to apologize for responding late, it's OK.

I'm very happy I could help you in your Degoogling or "Untracking" process.

Thank you so much for your reply. Feel free to open an issue if needed.
Sincerely,
Cyanic

Hi! I'm very sorry for what's happening right now to your wife and you. You don't need to apologize for responding late, it's OK. I'm very happy I could help you in your Degoogling or "Untracking" process. Thank you so much for your reply. Feel free to open an issue if needed. Sincerely, Cyanic

Good evening @Cyanic76 :

I wanted to ask a question if I may.

This hosts of yours https://hosts.cyanic.me/cyanicHosts.txt is included in https://hosts.cyanic.me/allhosts.txt .

And then if you incorporated in https://hosts.cyanic.me/allhosts.txt the new corporations that you put.

A hug and thank you for your time and help.

Good evening @Cyanic76 : I wanted to ask a question if I may. This hosts of yours https://hosts.cyanic.me/cyanicHosts.txt is included in https://hosts.cyanic.me/allhosts.txt . And then if you incorporated in https://hosts.cyanic.me/allhosts.txt the new corporations that you put. A hug and thank you for your time and help.
Owner

Hello!

I can confirm the new hosts are included into the all-in-one list. I believe that if you look for "riot" in the all-in-one file using the Look in page feature of any browser, you should find, at the time of writing, 26 results.

I added the list "riot" domains here.

If you want to take a look at the runs, here you go.

Happy to help!

Hello! I can confirm the new hosts [are included](https://codeberg.org/Cyanic76/Hosts/src/branch/pages/.woodpecker/merge_all.yml#L23) into the [all-in-one list](https://hosts.cyanic.me/allhosts.txt). I believe that if you look for "riot" in the all-in-one file using the *Look in page* feature of any browser, you should find, at the time of writing, 26 results. *I added the list "riot" domains [here](https://codeberg.org/Cyanic76/Hosts/commit/c59104494f0a7fc1cadd68eb3d257f0b07b854d6).* If you want to take a look at the runs, [here you go](https://ci.codeberg.org/Cyanic76/Hosts). Happy to help!

Good afternoon

First I apologize for my late reply. But I had to go with my father to the hospital, as he was unwell. Since not long ago he was operated on and of course ....

I was looking and what is inside https://hosts.cyanic.me/cyanicHosts.txt is at https://hosts.cyanic.me/allhosts.txt

So if I have the allhosts I can delete the cyanicHosts.txt to not overload Adaway.

Thank you very much for all your time and help.

Best regards

Good afternoon First I apologize for my late reply. But I had to go with my father to the hospital, as he was unwell. Since not long ago he was operated on and of course .... I was looking and what is inside https://hosts.cyanic.me/cyanicHosts.txt is at https://hosts.cyanic.me/allhosts.txt So if I have the allhosts I can delete the cyanicHosts.txt to not overload Adaway. Thank you very much for all your time and help. Best regards
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: Cyanic76/Hosts#2
Loading…
There is no content yet.