Create a Release #151

Closed
opened 7 months ago by n · 11 comments
n commented 7 months ago
Collaborator

Creating a release is poorly documented in the Tags and Releases article, which links to a section in the Citable Code article.

We should move that section to the Tags and Releases article instead, and link to it.

Creating a release is poorly documented in the [Tags and Releases](https://docs.codeberg.org/git/using-tags/) article, which links to a section in the [Citable Code](https://docs.codeberg.org/collaborating/citable-code/#creating-a-release) article. We should move that section to the Tags and Releases article instead, and link to it.
n added the
Kind: Documentation
Kind: Enhancement
labels 7 months ago
n added the
Status: Help wanted
label 7 months ago

What do you mean by poorly documented? It's not so terrible in my opinion 🤔

What do you mean by poorly documented? It's not so terrible in my opinion :thinking:
Collaborator

I think one point is that it's not really obvious where to look for it. Creating a release makes more sense in the Tags and Releases article as n suggested.

I think one point is that it's not really obvious where to look for it. Creating a release makes more sense in the Tags and Releases article as n suggested.

Personally I think https://docs.codeberg.org/collaborating/citable-code/#create-a-release-of-your-repository is pretty good.

The problem is, that it is part of the Citable Code section, so there is stuff you don't need if you don't need a citable code.

Personally I think https://docs.codeberg.org/collaborating/citable-code/#create-a-release-of-your-repository is pretty good. The problem is, that it is part of the Citable Code section, so there is stuff you don't need if you don't need a citable code.
n commented 5 months ago
Poster
Collaborator

Yeah, the "poorly documented" part of it is that it links to another not really relevant article, when the content should be in the article itself.

Yeah, the "poorly documented" part of it is that it links to another not really relevant article, when the content should be in the article itself.
n added the
Priority: High
label 5 months ago

Would it be a possibility to copy the Codeberg release part in an own page and set a link to the Cite-Code stuff?

Would it be a possibility to copy the Codeberg release part in an own page and set a link to the Cite-Code stuff?
n commented 5 months ago
Poster
Collaborator

Yes, that should be fine as long as the first paragraph is left in citable code.

Yes, that should be fine as long as the first paragraph is left in citable code.
I forked the documentation and tried the changes on Codeberg (I don't use git as software). Can you check it on https://codeberg.org/gerhardbeck/Codeberg_Documentation ? Changed files are https://codeberg.org/gerhardbeck/Codeberg_Documentation/src/branch/master/content/collaborating/citable-code.md https://codeberg.org/gerhardbeck/Codeberg_Documentation/src/branch/master/content/collaborating/release.md https://codeberg.org/gerhardbeck/Codeberg_Documentation/src/branch/master/content/git/using-tags.md
n commented 5 months ago
Poster
Collaborator

I don't think we need a seperate article for releases, and its contents can be moved to its segment in the Tags and Releases (using-tags.md) article.

Could you create a PR for your changes (Compare > New Pull Request)

I don't think we need a seperate article for releases, and its contents can be moved to its segment in the `Tags and Releases` (`using-tags.md`) article. Could you create a PR for your changes (Compare > New Pull Request)

Shall I move the content to tags and releases before creating a PR?

Shall I move the content to `tags and releases` before creating a PR?
n commented 5 months ago
Poster
Collaborator

The order doesn't matter, you can change the PR contents even after opening the PR. I will just wait for you to move the content before merging it.

The order doesn't matter, you can change the PR contents even after opening the PR. I will just wait for you to move the content before merging it.

Done: #163
Now the release on Codeberg is in tags and releases

Done: https://codeberg.org/Codeberg/Documentation/pulls/163 Now the release on Codeberg is in tags and releases
n closed this issue 5 months ago
Sign in to join this conversation.
No Milestone
No Assignees
4 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.