#99 deleted users cause a bug in issues list under some conditions

Closed
opened 7 months ago by Ghost · 8 comments
Ghost commented 7 months ago
  1. Open

  2. Scroll down and click page “3”

  3. template: repo/issue/list

1. [Open](https://codeberg.org/crimeflare/cloudflare-tor/issues?q=&type=all&sort=&state=closed&labels=0&milestone=0&assignee=0) 2. Scroll down and click page "3" 3. `template: repo/issue/list`
ashimokawa commented 7 months ago
Owner

This seem to happen when you close open issues that were opened by deleted users. I will have to find the root cause for that.

Fixed manually searching for the root cause.

This seem to happen when you close open issues that were opened by deleted users. I will have to find the root cause for that. Fixed manually searching for the root cause.
ashimokawa changed title from bug report to deleted user cause a bug in issues list 7 months ago
ashimokawa changed title from deleted user cause a bug in issues list to deleted users cause a bug in issues list under some conditions 7 months ago
Ghost commented 7 months ago
Poster
@ashimokawa Thank you for looking into this, but [it's happening again(just click "Closed" button)](https://codeberg.org/crimeflare/cloudflare-tor/issues)
ashimokawa commented 7 months ago
Owner

Thanks,

I reported that to gitea back then, the root cause is still unknown. But it is sure that it can be triggered more often by your “I delete my profile for every action” behavior. Still this is a bug!

I will do the workaround later again.

You could help by telling us exactly how your workflow is, when you do what (especially when you delete your profile). Or if you can find a way to reliably reproduce that on codeberg-test.org, try.gitea.io or gitea.com.

Thanks, I reported that to gitea back then, the root cause is still unknown. But it is sure that it can be triggered more often by your "I delete my profile for every action" behavior. Still this is a bug! I will do the workaround later again. You could help by telling us exactly how your workflow is, when you do what (especially when you delete your profile). Or if you can find a way to reliably reproduce that on codeberg-test.org, try.gitea.io or gitea.com.
Ghost commented 7 months ago
Poster

@ashimokawa We want this feature. #79

@ashimokawa We want this feature. https://codeberg.org/Codeberg/Community/issues/79
Ghost commented 7 months ago
Poster
@ashimokawa [OVER HERE](https://codeberg.org/TESTER/debugyou/issues)
hw commented 7 months ago
Owner

Pull request welcome! Properly done, we will absolutely deploy this.

Pull request welcome! Properly done, we will absolutely deploy this.
ashimokawa commented 7 months ago
Owner

We could reproduce the issue, thanks

We could reproduce the issue, thanks
ashimokawa commented 6 months ago
Owner

Fixed

Fixed
ashimokawa closed this issue 6 months ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.