Create new label sets #572

Open
opened 4 months ago by schorsch · 3 comments
Collaborator

Introduction

Currently there are two label sets: default and advanced. The advanced label set for example does not include the good first issue label since it does not fit within any category. Before implementing a messy workaround we thought about adding more label sets.

Remark

The label sets can be found at https://codeberg.org/Codeberg/gitea/src/branch/codeberg-1.16/contrib/options/label.

We will implement the new label sets on codeberg and propose our changes to upstream later since we decided to implement newer ones but we are not sure whether gitea wants them or not

# Introduction Currently there are two label sets: `default` and `advanced`. The `advanced` label set for example does not include the `good first issue` label since it does not fit within any category. Before implementing a messy workaround we thought about adding more label sets. # Remark The label sets can be found at https://codeberg.org/Codeberg/gitea/src/branch/codeberg-1.16/contrib/options/label. We will implement the new label sets on codeberg and propose our changes to upstream later since we decided to implement newer ones but we are not sure whether gitea wants them or not
schorsch self-assigned this 4 months ago
schorsch added the
enhancement
gitea-related
codeberg
labels 4 months ago
Poster
Collaborator

I just found an interesting label set which I created for a school project about a year ago

Prefix Label Description
Priority Critical Fix this NOW!
High Fix this in the next couple of days
Medium Fix this in the next few weeks
Low Fix this when you have nothing left to do
Status Backlog A large number of things that you should have done before and must do now
Work in Progress This is currently being worked on
Review Ready to be reviewed
Closed This issue or merge request is closed and will no longer be processed
Type Bug Something isn't working
Documentation Improvements or additions to documentation
Duplicate This issue or merge request already exists
Enhancement New feature or request
Question Further information is requested
Tag Good first issue Good for newcomers
Help wanted Extra attention is needed
Invalid This does not seem right
Wontfix This will not be worked on
I just found an interesting label set which I created for a school project about a year ago <table> <thead> <tr> <th>Prefix</th> <th>Label</th> <th>Description</th> </tr> </thead> <tbody> <tr> <td rowspan=4><b>Priority</td> <td>Critical</td> <td>Fix this NOW!</td> <tr> <td>High</td> <td>Fix this in the next couple of days</td> </tr> <tr> <td>Medium</td> <td>Fix this in the next few weeks</td> </tr> <tr> <td>Low</td> <td>Fix this when you have nothing left to do</td> </tr> </tr> <tr> <td rowspan=4><b>Status</td> <td>Backlog</td> <td>A large number of things that you should have done before and must do now</td> <tr> <td>Work in Progress</td> <td>This is currently being worked on</td> </tr> <tr> <td>Review</td> <td>Ready to be reviewed</td> </tr> <tr> <td>Closed</td> <td>This issue or merge request is closed and will no longer be processed</td> </tr> <tr> <td rowspan=5><b>Type</td> <td>Bug</td> <td>Something isn't working</td> <tr> <td>Documentation</td> <td>Improvements or additions to documentation</td> </tr> <tr> <td>Duplicate</td> <td>This issue or merge request already exists</td> </tr> <tr> <td>Enhancement</td> <td>New feature or request</td> </tr> <tr> <td>Question</td> <td>Further information is requested</td> </tr> </tr> <tr> <td rowspan=4><b>Tag</td> <td>Good first issue</td> <td>Good for newcomers</td> <tr> <td>Help wanted</td> <td>Extra attention is needed</td> </tr> <tr> <td>Invalid</td> <td>This does not seem right</td> </tr> <tr> <td>Wontfix</td> <td>This will not be worked on</td> </tr> </tr> </tbody> </table>
Poster
Collaborator

Suggested from Bart Hanssens: Eclipse - RDF4J

Name Description
bug this issue is a bug
cannot reproduce issue can not be reproduced (close reason)
dependencies Pull requests that update a dependency file
duplicate issue is a duplicate (close reason)
enhancement issue is a new feature or improvement
epic large issue consisting of multiple sub-tasks
good first issue issue is a good choice for getting started as a contributor
help wanted we could use your help in fixing this issue
internal task a project workflow/setup task not directly impacting end users
needs documentation Issue requires updates to the project documentation
not backwards compatible A change that breaks backwards compatibility and needs a major release
stable issue has gone stale (close reason)
tech debt code refactoring, deprecation, and other technical debt tasks
website/documentation Website update / Documentation issue
won't fix issue won't be fixed (close reason)
Suggested from [Bart Hanssens](https://twitter.com/BartHanssens/status/1489010004183113732): [Eclipse - RDF4J](https://github.com/eclipse/rdf4j/labels) | Name | Description | |:-------------------------|:-----------------------------------------------------------------------| | bug | this issue is a bug | | cannot reproduce | issue can not be reproduced (close reason) | | dependencies | Pull requests that update a dependency file | | duplicate | issue is a duplicate (close reason) | | enhancement | issue is a new feature or improvement | | epic | large issue consisting of multiple sub-tasks | | good first issue | issue is a good choice for getting started as a contributor | | help wanted | we could use your help in fixing this issue | | internal task | a project workflow/setup task not directly impacting end users | | needs documentation | Issue requires updates to the project documentation | | not backwards compatible | A change that breaks backwards compatibility and needs a major release | | stable | issue has gone stale (close reason) | | tech debt | code refactoring, deprecation, and other technical debt tasks | | website/documentation | Website update / Documentation issue | | won't fix | issue won't be fixed (close reason) |
Poster
Collaborator

Proposed the idea of modular issue sets to upstream: https://github.com/go-gitea/gitea/issues/18583

Proposed the idea of modular issue sets to upstream: https://github.com/go-gitea/gitea/issues/18583
schorsch added
upstream
and removed
codeberg
labels 4 months ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.