horizontal scrollbar non-existent when needed on markdown tables #482

Closed
opened 4 weeks ago by libBletchley · 4 comments

Very wide tables get cut off, such as this one:

https://git.disroot.org/cyberMonk/liberethos_paradigm/src/branch/master/usa_banks.md

One solution is to make the table wider than the display area and let the browser work out that a scrollbar is needed. The other option, which gitea has done traditionally, is to fix the width to the window width, and stretch cells vertically to fit all the text.

Not sure if this is a regression but currently on the above-mentioned page it just runs off the screen without a scrollbar.

Browser: Ungoogled Chromium
desktop: Wayland+Xwayland+Sway

Note that Ungoogled Chromium does not support wayland, so it could be an xwayland bug.

I would normally report upstream but I don't have (or want) Github access.

(edit)

Actually there is a horizontal scrollbar, but it's only accessible if you scroll down to it, at which point the rows you're looking at may have scrolled off. The problem is that there are 3 different horizontal scrollbars in fixed locations. It would be better to just have one horizontal scrollbar that's always visible for all 3 tables.

Very wide tables get cut off, such as this one: https://git.disroot.org/cyberMonk/liberethos_paradigm/src/branch/master/usa_banks.md One solution is to make the table wider than the display area and let the browser work out that a scrollbar is needed. The other option, which gitea has done traditionally, is to fix the width to the window width, and stretch cells vertically to fit all the text. Not sure if this is a regression but currently on the above-mentioned page it just runs off the screen without a scrollbar. Browser: Ungoogled Chromium desktop: Wayland+Xwayland+Sway Note that Ungoogled Chromium does not support wayland, so it could be an xwayland bug. I would normally report upstream but I don't have (or want) Github access. (edit) Actually there is a horizontal scrollbar, but it's only accessible if you scroll down to it, at which point the rows you're looking at may have scrolled off. The problem is that there are 3 different horizontal scrollbars in fixed locations. It would be better to just have one horizontal scrollbar that's always visible for all 3 tables.
Collaborator

That's a browser issue on how to present the scrollbar on overflowing elements. The scrollbar is defined for the scrollable element (the table in this case), and it's usually at the bottom of the element. Screenshot from Firefox:

image

The alternative would be to completely break the site's layout and have everything run out of the screen, but this would be super ugly.

That's a browser issue on how to present the scrollbar on overflowing elements. The scrollbar is defined for the scrollable element (the table in this case), and it's usually at the bottom of the element. Screenshot from Firefox: ![image](/attachments/267f8db3-991b-4c20-aee4-f05526f3dd57) The alternative would be to completely break the site's layout and have everything run out of the screen, but this would be super ugly.
Poster

yeah i can't think of a good solution to the problem, except perhaps a way to specify a better default font size. IIRC some markdown flavors might even support that (or maybe I'm confusing it with wiki tables).

yeah i can't think of a good solution to the problem, except perhaps a way to specify a better default font size. IIRC some markdown flavors might even support that (or maybe I'm confusing it with wiki tables).
Collaborator

I don't know if there are maybe CSS fixes possible to make the scrollbar stick to the bottom of the page, like, making sure the table element does technically not leave the browser window, but starts at the bottom and only the content within is scrolled or something.

Not a CSS expert though ...

CC @silverwind do you have an opinion? Can this be fixed upstream, should we transfer? Or should we rather transfer the issue to browser vendors to come up with a good fix for this? I mean, it would be kinda neat if browsers could just automagically make the scrollbar stick to where a user can use it ...

I don't know if there are maybe CSS fixes possible to make the scrollbar stick to the bottom of the page, like, making sure the table element does technically not leave the browser window, but starts at the bottom and only the content within is scrolled or something. Not a CSS expert though ... CC @silverwind do you have an opinion? Can this be fixed upstream, should we transfer? Or should we rather transfer the issue to browser vendors to come up with a good fix for this? I mean, it would be kinda neat if browsers could just automagically make the scrollbar stick to where a user can use it ...
fnetX added the
gitea-related
question
labels 3 weeks ago
Collaborator

Hmm, this is getting stale and I'm closing this, as I can't really think of a way to fix this in Gitea, apart from very hacky fixes that make the scrollbar stick to the bottom with the element.

People who are annoyed by this problem in general on websites: I recommend activating auto scroll, so you can hold the mouse wheel and scroll up / down / left / right by moving the mouse.

Hmm, this is getting stale and I'm closing this, as I can't really think of a way to fix this in Gitea, apart from very hacky fixes that make the scrollbar stick to the bottom with the element. People who are annoyed by this problem in general on websites: I recommend activating auto scroll, so you can hold the mouse wheel and scroll up / down / left / right by moving the mouse.
fnetX closed this issue 6 days ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.