Free as in Freedom: Codeberg.org. Create your repos!

#20 Avatar Settings Unclear

Open
opened 3 months ago by scott-joe · 4 comments

Having to click the “use custom avatar” radio button (it’s already “wrong” to have just a single radio button) isn’t intuitive. I uploaded an image, only to be hit with an error.

Having to click the "use custom avatar" radio button (it's already "wrong" to have just a single radio button) isn't intuitive. I uploaded an image, only to be hit with an error.
hw commented 3 months ago
Owner

We have currently disabled federated avatars, thus only the single option.

Not hiding the radio button looks indeed less than ideal, this would be a nice improvement to gitea. Pull requests welcome!

We have currently disabled federated avatars, thus only the single option. Not hiding the radio button looks indeed less than ideal, this would be a nice improvement to gitea. Pull requests welcome!
ashimokawa commented 3 months ago
Owner

@scott-joe

I cannot reproduce the error, how did you trigger it?

@scott-joe I cannot reproduce the error, how did you trigger it?
scott-joe commented 3 months ago
Poster

Because I’ve now got the only radio button checked, and I’m now within an established session, I’m unable to reproduce the issue. At the time, my theory was that having just authenticated my login the link emailed to me, my session wasn’t properly established. So, I logged out, back in, then realized the radio button was unchecked. I checked the radio button and the entire thing began working. I took a screenshot of the error. I’ll have to get on my other machine to provide it though.

Because I've now got the only radio button checked, and I'm now within an established session, I'm unable to reproduce the issue. At the time, my theory was that having just authenticated my login the link emailed to me, my session wasn't properly established. So, I logged out, back in, then realized the radio button was unchecked. I checked the radio button and the entire thing began working. I took a screenshot of the error. I'll have to get on my other machine to provide it though.
hw commented 1 month ago
Owner

If there would be a ‘default’ radio button choice, this would be fixed, I guess?

Maybe related: issue #1.

If there would be a 'default' radio button choice, this would be fixed, I guess? Maybe related: issue https://codeberg.org/Codeberg/Design/issues/1.
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.