Saving empty page borks entire site #71

Closed
opened 6 days ago by dixonge · 7 comments
dixonge commented 6 days ago

Problem

Tried saving an empty page, as a place-saver. Started getting minimal page with a message stating that editing required javascript. Links to other pages change the URL but don't open until you reload, but then you still get the minimal page.

Expected Behavior

Expected page to simply save

Steps to Reproduce

As described in Problem section

Details

  • I am using this build: Dove
  • I am using this version: 1.3.1
  • I am using this browser: Chrome (latest version)
## Problem Tried saving an empty page, as a place-saver. Started getting minimal page with a message stating that editing required javascript. Links to other pages change the URL but don't open until you reload, but then you still get the minimal page. ## Expected Behavior Expected page to simply save ## Steps to Reproduce As described in Problem section ## Details <!-- Please enter the correct data --> - **I am using this build:** Dove - **I am using this version:** 1.3.1 - **I am using this browser:** Chrome (latest version)
dixonge added the
bug
label 6 days ago
Owner

Hi @dixonge, I can't reproduce this on my computer, so I have to ask some troubleshooting questions.

  1. Did the pre-load page start displaying immediately after you clicked "Save" when creating the blank page, or did it only start doing that after you saved and re-loaded the wiki file?
  2. Did you use the "Save Wiki" button to save, or did you save using the browser's Ctrl+Save option (sorry for this question, but it must be asked)
  3. Do you have any Custom JS added to the wiki?

Finally, would you be willing to share that broken Feather Wiki so I can see what might be wrong with it? You should be able to attach it as a file here.

Hi @dixonge, I can't reproduce this on my computer, so I have to ask some troubleshooting questions. 1. Did the pre-load page start displaying _immediately_ after you clicked "Save" when creating the blank page, or did it only start doing that after you saved and re-loaded the wiki file? 1. Did you use the "Save Wiki" button to save, or did you save using the browser's Ctrl+Save option (sorry for this question, but it must be asked) 1. Do you have any Custom JS added to the wiki? Finally, would you be willing to share that broken Feather Wiki so I can see what might be wrong with it? You should be able to attach it as a file here.
Poster
  1. Yes, when I clicked Save, nothing happened, so I tried adding some text and hitting save again. Nothing. Then I tried going to other pages. The URL would change, but the page wouldn't load. I hit refresh, and then the page loaded, but just the sidebar w/ the javascript message (see previous attachment)

  2. Save Wiki button - didn't realize there was a Ctrl+S option!

  3. Yes, I have the Marked.min.js code, but I also tried saving and reloading with that code removed. It did not fix the issue.

File attached.

1. Yes, when I clicked Save, nothing happened, so I tried adding some text and hitting save again. Nothing. Then I tried going to other pages. The URL would change, but the page wouldn't load. I hit refresh, and then the page loaded, but just the sidebar w/ the javascript message (see previous attachment) 2. Save Wiki button - didn't realize there was a Ctrl+S option! 3. Yes, I have the Marked.min.js code, but I also tried saving and reloading with that code removed. It did not fix the issue. File attached.
Owner

I should say first that there is not a Ctrl+S option, I just wanted to make sure you hadn't used that because it would not have saved correctly.

Thanks for sharing that! I've figured out what's wrong, and it's specifically to do with the Markdown parser, which I didn't realize--my bad! The problem is that the content key is not included in the data at all, which causes the parser to attempt parsing a nonexistent value. I'll make sure the next version (coming very soon) fixes that problem! The next version is also replacing the default markdown parser with a better one, but you might still be happier with Marked since the new parser still won't include table support.

I've fixed your wiki and attached it here! Until that new version with the fix comes out, just make sure to type at least one letter into the page content. Sorry for the inconvenience!

Finally, I'll comment here and close the issue when the fix is available.

I should say first that there is _not_ a Ctrl+S option, I just wanted to make sure you hadn't used that because it would not have saved correctly. Thanks for sharing that! I've figured out what's wrong, and it's specifically to do with the Markdown parser, which I didn't realize--my bad! The problem is that the `content` key is not included in the data at all, which causes the parser to attempt parsing a nonexistent value. I'll make sure the next version (coming very soon) fixes that problem! The next version is also replacing the default markdown parser with a better one, but you might still be happier with Marked since the new parser still won't include table support. I've fixed your wiki and attached it here! Until that new version with the fix comes out, just make sure to type at least one letter into the page content. Sorry for the inconvenience! Finally, I'll comment here and close the issue when the fix is available.
Poster

Looks good, thanks!

I was already trying to insert some default text in there, but once it got borked I couldn't find what to remove to reset it.

Me <--- not a Bash programmer. I am a copy-pasta programmer 💯

I only have one site (so far) w/ a table and I had to create it in raw html ugh

So - if Marked has that it would be nice, but probably not needed for most of my sites.

Looks good, thanks! I was already trying to insert some default text in there, but once it got borked I couldn't find what to remove to reset it. Me <--- not a Bash programmer. I am a copy-pasta programmer 💯 I only have one site (so far) w/ a table and I had to create it in raw html *ugh* So - if Marked has that it would be nice, but probably not needed for most of my sites.
Owner

Yeah, unfortunately the bug was such that the moment you clicked save with no content the first time, Feather Wiki choked and it couldn't be fixed from the UI at all... Obviously not great, so I appreciate you letting me know about it!

But yes! Using that custom JS that adds Marked gives you the full power of Marked, which does include GitHub-Flavored Markdown by default, including table support. I know the frustration of using raw HTML for tables, so I imagine being able to use Markdown again will be a relief.

Yeah, unfortunately the bug was such that the _moment_ you clicked save with no content the first time, Feather Wiki choked and it couldn't be fixed from the UI at all... Obviously not great, so I appreciate you letting me know about it! But yes! Using that custom JS that adds Marked gives you the full power of Marked, which does include GitHub-Flavored Markdown by default, including table support. I know the frustration of using raw HTML for tables, so I imagine being able to use Markdown again will be a relief.
Poster

Thanks for sharing that! I've figured out what's wrong, and it's specifically to do with the Markdown parser, which I didn't realize--my bad! The problem is that the content key is not included in the data at all, which causes the parser to attempt parsing a nonexistent value.

One other factor in this scenario is that I had previously successfully saved blank pages, so the glitch caught me off guard. Obviously my previous successes were using the regular editor mode, not markdown!

> Thanks for sharing that! I've figured out what's wrong, and it's specifically to do with the Markdown parser, which I didn't realize--my bad! The problem is that the `content` key is not included in the data at all, which causes the parser to attempt parsing a nonexistent value. One other factor in this scenario is that I had previously successfully saved blank pages, so the glitch caught me off guard. Obviously my previous successes were using the regular editor mode, not markdown!
Alamantus added this to the 1.4.0 milestone 6 days ago
Owner

The new 1.4.2 version (available on the website) now includes the fix that will prevent this from happening again!

The new 1.4.2 version (available on the website) now includes the fix that will prevent this from happening again!
Alamantus closed this issue 4 days ago
Sign in to join this conversation.
Loading…
There is no content yet.